Incredibly Frustrated: Third Clip that has ceased to work

Product: Sansa Clip (4gig)

Operating System: Windows XP 

Problem: Ugh, where to start?

I’m personally EXTREMELY frustrated with Sansa because I’ve had no less than three 4gig Clips stop working on me for no discernable reason. One after about five months, one after no less than three, and this one after about three months as well. If that.  I’m not illiterate with technology or MP3 players by any means, nor is there a lot of wear and tear going on here, I just took my Mp3 player out when I went to excercise.

The tech support’s advice never, ever fixed the problem either. On each one, I’ve gone through that song and dance of reinstalling/updating the firmware/holding the power button to reset it. This didn’t work. Ever. I always had to exchange for a new one.

Not only that, my most recent Sansa had USB connection issues less than a week after I purchased it. Initially, the Clip would allow me to transfer and delete files (All in MP3 format, nothing odd) at my will. Then, while transferring a rather large folder of one of my favorite artist’s discographies, the transfer froze. From that point on, I could open and look at the music folders just fine but couldn’t add nor delete anything. This was a problem I never had with the first two.

I was told that if I switched the transfer method from Auto to one of the set methods (I went with MTP, I believe) that it should solve the problem. And it sort of did. I could now transfer files to the computer, but all the other files I had transferred using the previous Auto method had gone invisible when I looked at the drive on my computer yet were still there on my MP3 player. It wasn’t that huge of a deal, just frustrating because there were some songs I wanted to delete that I couldn’t because I COULD NOT FIND THEM to even delete them. But whatever, I lived with it. I liked most of the songs on my player anyway, what harm was it in skipping over a few I didn’t want?

There were a few times where the Clip would freeze up on me if I tried to explore my MP3s and I’d have to reset it but this was fairly rare and resetting was no biggie.

Livable problems, I thought I finally had a Sansa that, while bratty, was working for me.  I was listening to it yesterday just fine while I was out riding my bike. It wasn’t dropped or manhandled in anyway, so damage is not the issue.  When I put it back in my backpack, it had plenty of juice left and turned off normally. I did not connect it to my computer, so some short or update issue couldn’t be it either.

Suddenly, today, it ceased to work. I can not turn it on. Not only that, but when I connect it, my computer detects it as an external harddrive but I can not access it. It also doesn’t show the “charging” screen. My other two Sansa’s that stopped working would show the charging screen, but simply refused to turn on after being disconnected.

I’m at the end of my darn tether here and I apologize if I sound so moody but… I remind you, this is my third player that has ceased to work and not a single one has made it past the one-year mark. I think my frustration as a consumer is justified. 

I also worry that if I try to send this one back, Sansa may think I’m running some sort of scam scheme or something because, as I said, this has happened multiple times.

What do I do? Am I just seventy-odd bucks in the hole and should just go to another brand or try a different type of Sansa product? I don’t know.

I forgot to mention that for whatever reason, when I try to charge my Clip, the device gets REALLY hot to the touch for some strange reason. As in, I’d half-expect the thing to burst into flames.

Also a reminder, I can not access the device at all and therefor it may be a battery issue. Updating the firmware is not an option with this one because I can’t even get the darned thing to communicate with my computer.

Your problem appears identical to the problem with my 4GB Sansa Clip although I have used mine almost daily for over a year

Your problem appears identical to the problem with my 4GB Sansa Clip although I have used mine almost daily for over a year. I cannot update the firmware, add or delete any song either from Windows (explorer or media player program)

I have tried to reformat the player, reset it, using the windows program to reformat the player - none worked so far, all music files remained intact and playable after all these steps.

I am still looking for workaround solution.

Good luck to all

dermetz, so WHAT are you doing to destroy these devices?  It sounds to me like you are ‘frying’ them by overcharging somehow, perhaps an overvoltage charger?

I have two clips and ZERO problems.  NONE.  

I have a 8gb clip and I can’t get it to do anything but charge

I have done the firmware thing but still it is not in my computer

Not only that but the songs that where on the clip when it first came on are gone.

I have had it for 24hrs and I am ready to take it back to the store

I also have a philips mp3 and have not had one problem

Your problem with not finding files are as you have indicated a MSC / MTP issue. I do not think that issue is specific for Sansa. I had a XP pc where I was not at all able to see the Sansa in either mode. It was solved when I followed the Q&A*wj&p_brand=sansa&p_accessibility=0&p_redirect=&p_lva=&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfcm93X2NudD0yMjksMjI5JnBfcHJvZHM9JnBfY2F0cz0mcF9wdj0xLjQmcF9jdj0mcF9zZWFyY2hfdHlwZT1hbnN3ZXJzLnNlYXJjaF9ubCZwX3BhZ2U9MQ**&p_li=&p_topview=1

SOLUTION 7 - Set user restrictions.

Some computers have user right restrictions that are set to disable access to new hardware.

STEP 1 - Log-in as an Administrator

STEP 2 - Edit restriction

NOTE: Disconnect the Sansa player if connected.

  1. Click Start  then Run ,
  2. Type cmd , then the press Enter.
    3. After the prompt, type Net localgroup Administrators local service /add then press Enter.

STEP 3 - Reconnect your device

Your other problems could indicate that you have an overcharging USB on your PC or charger. Check the USB voltage.

I have had the same problem happen to me twice. First with a 2GB after a year, then with a 4GB after about the same amount of time. I love to ergonomics, sound quality and features of the clip, but I don’t think I’m willing to buy a new one every year just because it just stopped working!  I’ve tried everything also but to no avail. Sadly, I think I will just have to go with another more reliable brand more next time (God forbid I buy a iPod!).