I sold my Sony USB MP3 for a Sansa Express. What a mistake...

They had the exact same features and Sansa had expansion for MicroSD.

Pure win right?
How different could a USB style MP3 player be right?
Just plug and play right?

Wrong.

The Sansa Express is a disaster.
It didnt read my microSD card out of the box and couldnt even fit in my side USB port.

I installed the newest firmware and the microSD was found but the actual player sucks.

It shut off in mid song 5 times in two days.
The Sony never shut off once.

I figured if Sony has such a bad rep and their player is this good then the Sansa must be even better.

Now I’m stuck with a shiny black stick that can’t even play a song without shutting off and that’s with the newest firmware.

Shame Sandisk.
I try to sing the praises of non-Apple MP3 players to my friends but I’d be ashamed if I recommended this to somebody.

FWIW,  here is a copy of the tech support they sent me about this issue…

Hello,

Thanks again for contacting SanDisk Technical Support.

To fix the issue you are having with your player, you will need to apply a firmware update while the player is in recovery mode.

To enter recovery mode:

  1. Disconnect and turn the player off.

  2. Turn the hold switch on top of the player on, so the orange is showing.

  3. While holding the record button down, plug the Sansa into the computer, and coontinue holding the record button for 5 seconds.

  4. You will then see a message displayed on the Sansa about entering USB recovery mode. If not, repeat steps 1-3.

Once the player is in recovery mode, please download and run the firmware utility, located at the following link:

http://www.sandisk.com/assets/file/downloads/firmware/e200fw01.00.12.exe

Follow the utility’s on-screen instructions. When it asks you if you want to format the Sansa, choose no.

After you are finished updating the firmware, disconnect the Sansa. Watch the screen of the Sansa and when it says “Keys locked, system shutdown” turn the hold switch off, and power the Sansa on.

If you still get the same error, place the Sansa into recovery mode and run the firmware utility again, only this time when it asks you if you want to format the Sansa, choose yes. This will erase everything that is on the Sansa.

The reason why the Micro SD card is not working is because the Sansa only supports up to 2GB cards. We will be releasing a firmware update soon that will provide Micro SDHC support.

If you should have further questions or concerns, please don’t hesitate to reply to this e-mail or contact our Technical Support department at 866-SANDISK (866-726-3475). Have a great day and thank you for choosing SanDisk.

Best regards,
Matt A.
SanDisk Technical Support

PS: If applicable, please take a moment to update your Ebox account with product as well as personal information (no P.O.BOX). Please include place and date of purchase of the product.

Um, thats e200 firmware… its not meant for the express.

If your having so many problems buddy, try contacting sandisk to have them fix it. Part of buying a companys product is how well the company responds to demand. if i were in your shoes I would be upset to.

But if sandisk fixed / replaced my problem, my opinion would change drasticly. Have you given them to chance to do so?

HR,

What firmware is exactly on your device?  You said the newest firmware, is it 1.01.05?  I have the same firmware and did not see this problem.  I’m kinda curious to see exactly how it happened though.  Like what kinds of music contents you put in there? Did the player turned off because the song track is bad or not compatible.  You can check to make sure those things are working

Sorry for giving you the wrong info. :( 

Have you tried formatting it? That usually takes care of strange issues like this.

Try the procedure given in the 42nd post here:

http://forums.sandisk.com/sansa/board/message?board.id=express&thread.id=983&page=5