I need help with my sansa clip!

i JUST got it for a christmas present. i plug it into my computer and pick out all my songs. it says that they were transferred to the player but i go to turn it on and theres nothing. so my dad told me to leave it plugged in to charge. we did that and my dad tried putting songs on. but it reads the player as being full when really theres nothing on there. and now when we go to turn it on its froze at refresh database. its starting to get really frustrating!!!

I’m having the same trouble…Some-one know how to help us?

Try removing the USB plug from the computer.  Then plug it back in and from My Computer read where the Clip is located, click on it, and check memory, delete all songs from the Clip, that should clear the Clip up to reload.  But… when transfering songs, make sure that they are synchronized into the clip by clicking on the synchronize tab on the lower righthand portion of the screen.  I found this out by trial and error.  It doesn’t hurt to try.  Good luck!

I hope this isn’t too obvious - but make sure that the mp3 files go into the MUSIC folder.

Make sure you are using Windows Media Player 11.

If you try to use WMP 9 the songs will load but not appear on the Sansa Clip.

I’m having the same problem.  According to the Sansa Quick Start Guide, my Sansa Clip should appear in My Computer when it’s plugged in.  However, My Computer doesn’t seem to recognize the device, whatsoever.
What’s more:  I tried bypassing that way of downloading songs, alltogether, by using Windows Media Player to “Copy to a CD or Device”.  According to WMP, I have songs on my Sansa; but according to my Sansa, I’ve got nothing. 
What.  Do.  I.  Do?

Good advice,  Firefly!  Downloading Windows Media Player 11 cured my problem!
Thanks :womanvery-happy:

Upgrading to Windows 11 worked for me!  Thank you :smiley: Merry Christmas!