i have .dat files but my vault is empty


My files are no longer tied to my vault

I always have my folder with the files .dat
But when I open the application … the vault is empty.

How to recover my files?

1 Like

I have the same issue! What can I do now?

I also have this same issue… surely someone knows how to get the .dat files back to an associated vault… We know the password to decrypt… we just can’t get the file back into a vault so secure access can actually decrypt them…

I refuse to believe that we can’t find a solutiuon to this problem… the USB stick still acknowledges my 16+ GBs of data… I just can’t retrieve it via a “vault”…

There is simply no way that sandisk and encrytpstick would come up with a software that randomly stops recognizing the .dat files belonging to a vault when the password was not lost…


Same problem…I updated to V2.0 and added folders to the vault no problem. Next time I signed in the folders were gone!! The dat files are there but I can’t get the folders to re-appear. How to recover from this problem. Anybody? Hello?

Please try the steps mentioned below and let us know if it works:

Open the root directory of the flash drive.

  • Open the SanDisk Secure Access Vault folder.
  • Open the System files folder.
  • In the system files folder there will be 2 index files. One with an extension of .idx and one with the extension .idx.bak.
  • Rename the file with the extension .idx to .idx.old.
  • Rename the file with the extension .idx.bak to .idx.
  • Access the root directory of the flash drive again to log in to the Secure Access application.

This created a new idx file but didn’t solve the problem. Folders are still not visible…

Anyone make any progress on the missing files problem?

1 Like

Did anyone solve thier issue?

Same issue… still no solutions?


   Even I have the same issue I have .dat files but my valut is empty anyy suggestions

C’mon Samsung, it’s been over a year! How do we retrieve our lost data??

@peterh401ri wrote:

C’mon Samsung, it’s been over a year! How do we retrieve our lost data??

I think you’re lost . . .


Hi, are you still interested in recovering your data or you got rid of your Vault and/or USB Stick?

I can help you save it if you are still interested in recovering your data.

Re: Invalid Parent Path in Archive


‎12-22-2019 09:24 AM

Try this, it worked for me, probably, until the next time it doesn’t…using version 3…maybe works with version 2?

Each time you do a “repair” it basically creates a new index.dat file. I found my index.dat file by following this rabbit hole: clicking the “SanDiskSecureAccess Vault” file with a vault icon -> scrolling to the bottom -> that’s where the index.dat lives (rather, repeatedly dies). I’ve had index.dat, indexdat (without the “dot” as mentioned elsewhere), index.dat (2), index.dat (3), etc etc. 

DELETE them all. That’s right, delete all of the index.dat files as you’d like to delete Sandisk (or others in bed together) from your life permanently for this annoying tactic to bridge you into the cloud and thereby make it easier for you to lose all data (and a fortune with monthly payments) to nefarious backroom deals regarding “security” and “privacy”. It’s scary, yes, be brave. At least you might learn a little. 

Do a final “repair”. It will make an index.dat file. Yaye. This time it seems to be linked and synced…until the next time it isn’t of course…or until it’s “no longer supported”, as if it was in the first place.

Tips: Don’t ever love a company, it’ll never love you back. Love people instead. Dogs are people too. Perhaps buy an alternative brand to SanDisk, and back up to them as well. Now you’ve got SanDisk, and some other brand, each with your data in case one is targeted. Keep your usb, ssd, etc in an electrostatic bag, then a ziplock, then a fireproof box (or buy a safe deposit box and keep data off-site but rely on, and pay, the bank). BestBuy gave me some free e-bags when they continually screwed the pooch. You can buy some. Don’t mess with the other files, they’re there “for your security, so that everything will be okay, and the situation is contained”. Just click the SanDiskSecureAccessV3_win, enter your password, and hope you aren’t dooped again. Mac people, no idea what your problems are, but they’re probably similar. 

Alternatively, don’t use Sandisk if their support isn’t up to par. Go and get some fresh air ; ) while we still have some…

By, for, of, 


P.S. (5 years after the original post, lol)