Invalid Parent Path in Archive

Secure Access V2.0 returned an error when I tried to open my vault. After I type in the password I get the error message, “Invalid Parent Path In Archive”.  When I click ‘OK’ I get the standard “4 Ways To Protect Your Data” screen as usual when I open a vault. When I click the 'Next" button I get the error, “This vault could not be loaded, it may be located on another computer or the original vault file has been manually removed.” After I click OK the main screen opens. It has the vault listed, but if I click on it I get the same error message.  Whats going on? How can I access my vault? It is my backup for important documents and archives.

No, I haven’t moved or deleted the vault. The vault is located on the memory stick.I only work from one computer running Windows 7. This particular Sandisk 32 Extreme is never used with any other computer. I haven’t changed the password. Everything was working fine until I just couldn’t sign in.


There are some steps you can try in order to recover the vault files .

  1. copy the vault and secure access application from the write protected drive over to the new drive

  2. run secure access on the new drive

  3. when it prompts to create a new vault go ahead and create a new vault with the exact same password as the old vault

  4. encrypt any file in the new vault (this will generate two new system files)

  5. close secure access

  6. open the vault folder on the new drive via windows explorer, navigate to the system files folder, you should see several files, among them are two sets of "USB Flash Drive-XXXXXXXXXXXXXXX.idx and .bak files

  7. Looking at the date stamps of the files, 2 will be older and 2 will be newer (you can also check on the old write protected drive to confirm the names of the older files, the older files contain the encryption information needed however the file name is associated with the previous drive we will need to rename the old files)

  8. copy the 2 newer files and paste them into any temporary location outside of the flash drive (i.e… desktop)

  9. once you’ve copied the two new files to a temporary location delete the originals from the system files folder on the flash drive.

  10. go to the temporary location and copy only the file name from the .idx file (the file name, not the file itself)

  11. go to the vault / system files and rename the old .idx file with the name you copied from the new .idx file

  12. repeat the same for the idx.bak file

  13. now you should have renamed the old .idx and .idx.bak files with the names of the newly generated system files.

Deponia… Here is my issue… along the same lines…

When I tried to log in to my vault it said invalid archive…

I still have the system files full of the .dat files and I know the password… How I can get to where SecureAccess recognizes the vault again… or at the very least I can put the .dat files back under a new root directory so that I can decrypt them…

I have tried moving the system files folder over to my external HD… then opened a new vault with SAv2 using the same password then moving the .dat files into the new system files folder just as they appear before but when you open the vault it does not display these files…

Is it because of new .idk.bak file created?

Any help would be great… I have irreplaceable photos of my infant child on this thing!!


if you tried the steps and you still cant recover the files from the vault i would suggest providing pictures of the error message and the files to sandisk support so they can help you recover the files from the vault

i hope you can recover your important data from the drive.


.idx and .bak nowhere. How do I restore your important data?


OMG - v3.0 Invalid parent path in archive.

But I do not have a second sandisk drive laying around - what is the fault that caused this please?

Is there a workaround, since this problem is obviously not new?


Thank you, data_guy


Same problem happend to me just now.

SanDisk customer support was helpless.

The level 1 and Level 2 tech didn’t even know about re-naming a file. At every step, they only read from a script.

Re-installing the executable did NOTHING.

After the PW, the same error message came up (EVERY time): " Invalid path in archive"

Loading different versions of the SecureAccess did nothing.

(then they tried to blame the version difference on me).

Three hours of my life never to get back.

At the end, all they said was “sorry for the inconvenience”  and 60 GB of encrypted data blown to electron dust.

All they cared about was the USB drive worked, and since Encryptstick wrote the software, SanDIsk is incapable of supporting it.

Come on guys: software can be fixed !!

This is so totally ridiculous! I have many other flash drives and will probably buy many more but I will NEVER NEVER EVER BUY ANOTHER SAN DISK AGAIN!!!

I just read all the posts above trying to fix the same problem and have been trying to access my very, very important files on a 128gb flash drive (wow- especially will warn people not to invest in another 128gb or larger drive when they are going to fail!! big money loss on top of time-waster!).

None of the things i’ve tried have worked. SanDisk has NO BUSINESS SELLING A FEATURE ON A FLASH DRIVE THAT DOES NOT WORK!!! 

Can’t spend any more time on this stupid project. I hope people read these posts before they ever consider buying one of their products again.

“1) copy the vault and secure access application from the write protected drive over to the new drive”

There is no “new drive”


Hi, are you still interested in recovering your data or you got rid of your Vault and/or USB Stick?

I can help you save it if you are still interested in recovering your data.

The following worked for me and I had the same invalid parent path error using a 256gb sandisk USB encrypted drive knowing my password was correct. I opened the secure vault folder and renamed the index.dat file to indexdat (removing the dot “.”). I launched the sandisk secure vault executable and entered my password. I got logged in and got a index.dat error message asking if I wanted to repair. I said yes. After an exhausted repair process (about 2 hours) it repaired it and all my files were accessible again.

HELP. Removing the dot on the index worked, forcing it to reindex. Only took about a minute.

But…it keeps getting corrupt. 3 times in 2 days. How do I stop it from getting corrupted?

Didn’t work for me!!!

But it obviously repaired some corruption for you?

I would do the process again, move off all the data, and use some other type of encrypted USB drive. I can’t tell you why it keeps doing it. Mine has been fine ever since.

@Blackbill44, yes it reindexed everything perfectly.

 Try right click on usb flash drive icon, properties and click on Repair Vault. It works for me. Hope this helps.


Try this, it worked for me, probably, until the next time it doesn’t…using version 3…maybe works with version 2?

Each time you do a “repair” it basically creates a new index.dat file. I found my index.dat file by following this rabbit hole: clicking the “SanDiskSecureAccess Vault” file with a vault icon -> scrolling to the bottom -> that’s where the index.dat lives (rather, repeatedly dies). I’ve had index.dat, indexdat (without the “dot” as mentioned elsewhere), index.dat (2), index.dat (3), etc etc. 

DELETE them all. That’s right, delete all of the index.dat files as you’d like to delete Sandisk (or others in bed together) from your life permanently for this annoying tactic to bridge you into the cloud and thereby make it easier for you to lose all data (and a fortune with monthly payments) to nefarious backroom deals regarding “security” and “privacy”. It’s scary, yes, be brave. At least you might learn a little. 

Do a final “repair”. It will make an index.dat file. Yaye. This time it seems to be linked and synced…until the next time it isn’t of course…or until it’s “no longer supported”, as if it was in the first place.

Tips: Don’t ever love a company, it’ll never love you back. Love people instead. Dogs are people too. Perhaps buy an alternative brand to SanDisk, and back up to them as well. Now you’ve got SanDisk, and some other brand, each with your data in case one is targeted. Keep your usb, ssd, etc in an electrostatic bag, then a ziplock, then a fireproof box (or buy a safe deposit box and keep data off-site but rely on, and pay, the bank). BestBuy gave me some free e-bags when they continually screwed the pooch. You can buy some. Don’t mess with the other files, they’re there “for your security, so that everything will be okay, and the situation is contained”. Just click the SanDiskSecureAccessV3_win, enter your password, and hope you aren’t dooped again. Mac people, no idea what your problems are, but they’re probably similar. 

Alternatively, don’t use Sandisk if their support isn’t up to par. Go and get some fresh air ; ) while we still have some…

By, for, of, 


P.S. (5 years after the original post, lol)

It is dec 2019. I got the same problem on my iXpand mini drive - invalid password when getting into vault on iPhone.
I search on internet n can’t find a solution.
Somehow I plug the drive into pc n same issue when accessing vault but the error is diff - invalid parent path in archive.
Search using this n find a hint to solve. ( thx jb12345 ).
In computer, open folder - iXpand n rename the file index.dat to indexdat ( remove “.” )
Then open the vault again n will ask to repair the index.
After some time ( depends on how many vaults ), it is done.
Can access back the vault using password - no error. But the secured data might not be recovered. It depends how u put the files / photo into the vault before.
If it is copied from iPhone to iXpand then secured , sorry can’t recover the correct index n can’t see the data.
If it is copied using usb from pc to iXpand drive, it is able to access back.
Also i can reproduce the error by exporting WhatsApp chat history n save into iXpand drive . This will ruin the index n cause the error. I guess when moving data into iXpand drive by other app inside iPhone , will cause the error.
Better use the iXpand app to copy photo , music … for data like WhatsApp chat history , I export to a certain place in iPhone, then copy it using app like FILES or FOLDERS into iXpand drive.

The only thing that ended up working for me was to delete the index file and then repair (as others have suggested), but then immediately back-up the vault to my hard drive before trying to open the vault. After then restoring from the back-up to the thumb drive everything was OK and I could access the vault and transfer the files to another device. 

I’ve renamed the index.dat folder, deleted it, tried to repair the vault, NOTHING is working. This isn’t the first time Sandisk has fucked me over with my data! WHEN WILL IT END! I never want to use a godforsaken sandisk USB ever again! I just want to finally copy my files to a USB I can TRUST WITH MY DATA!
Edit: It has mysteriously allowed me to repair the USB vault again. I do not know why. I am convinced this software is possessed.

im afraid my vault missing. how?