I cannot get my 4G Sansa Fuze to charge beyond 52%


I am new here and would appreciate any suggestion or help. I have had my Sansa Fuze since December 2008. I cannot get my 4G Sansa Fuze to charge beyond 52%. When I plug it it in to the wall charger or the computer it seems

to be charging and I leave it alone for an hour. When I look at it at this point it is no longer charging, the battery is full and it says “Connected”. I then remove the cable and after it refreshes the media the battery goes back to half full. I love my Sansa Fuze but this problem is frustrating. I have been having this issue for 4 days now. I have read some of the posts here and tried some of the solutions.

1)So far I have updated the Firmware version.

  1. I have changed the USB mode to MSC.

Please help me I don’t know what else to do.

try letting the fuze drain fully(till unit shuts off) then charge it, it could just be an error that will clear up if you reset the batt’s charge chip(cant remmber proper name)

Thanks I will try it and let you know.

The battery might indeed be fully charged even though the indicator says 52%. When you run down the battery completely before charging it again, see how long it plays. If the battery is not run down to 20% or less at least around once a month, the battery indicator will get less and less accurate over time. Running the battery down until the player stops then charging it will probably reset the battery indicator. If not, then run it down completely again before charging it.

That may be the problem of the Batteries. Why not replace it.

I have the same problem before.

The battery in the Fuze is not easily replaceable. It is hard enough finding a reasonable priced battery that will fir in the space and that has enough power. Getting the player open, changing the battery, then closing it properly does not seem easy. If the player still works but battery capacity isn’t enough, then getting an external battery pack seems much easier. They sell for as little as around $10.

Thank you all for your help.  I will keep you updated as to what happens. The battery is currently at 42%. JK98 where can I buy an external battery pack?

" JK98 where can I buy an external battery pack? "

You can find them on the Amazon website. There are those like the Tekkeon mp1550 and Fiio P3 that use AA nimh batteries, and Lion battery based ones like the Duracell Instant Power, Tekkeon mp1800, and others.

I have the Tekkeon mp1550 and like how it works with 4 nimh batteries. I have not tried it with alkalines or with just 2 batteries.

Here is a solution for the brave!

Yes, fellow Sansa fans, that’s a genuine 550mAh LiPo, available at Radio Shack.  They are mislabeled in the website as 5500mAh.  Apparently, this is a solder-in replacement.  I would NOT recommend this option if your Sansa is still under warranty.  If you don’t have an 8G model, it might be preferable to purchase a new device, solving the memory capacity upgrade in the process, plus giving you a new warranty-covered Sansa in the process.

Rebuilding your Fuze is a project best done if you are old school, used to fine soldering, and know what QSO and BFO stand for, have a working knowledge of Morse code, and think nothing of climbing the backyard tower for a radial beam antenna alignment.

Run that LiPo down until “battery low, system shutdown” appears, then recharge fully, before worrying about your Fuze’s battery.

As an alternative, find a local Ham to assist in replacing that battery, if you so desire.  Look for the pickup truck replete with DX antennas and a four-character amateur license plate, or the neighborhood home with the tower in the yard.

Bob  :stuck_out_tongue:

LOL! That Radio Shack battery is $35! One can buy a new 4 GB Fuze for $55, or perhaps a refurbished one for $35 and avoid the trouble of the repair.