How to install RockBox onto Clip+ Ultimate n00b Thread. Utter fail inside.

So I sold my gen6 ipod nano for a clip+.  The clip+ just came in the mail today and I have to say it sounds like crap compared to the old ipod nano.  I’m hoping rockbox can fix this.  I figured it couldnt be any harder installing this than any of the apple products BUT BOY WAS I WRONG.  

I’ve spent the last 3 hours trying to figure out how to get rockbox onto my clip+ and I’m still on the 1st step.  Getting ready to send this POS back.  I’ve already searched youtube, i tried following the rockbox site, searched head-fi and this forum.  

No information listed at any of these sources has helped.

So I got the rockbox program downloaded.  I open it and I have two options.  

Complete Install

and

Minimum install

Either one I click on I get this message

“Bootloader installation requires you to provide a copy of the original Sandisk firmware (bin file). This firmware file will be patched and then installed to your player along with the rockbox bootloader. You need to download this file yourself due to legal reasons.  Please browse the sansa forums or refer to the manual and the SansaAMS wiki page on how to obtain this file.  Press OK to continue and browse your computer for the firmware file.”

I tried getthing this file from multiple sources… ERROR, ERROR, ERROR, ERROR, ERROR, ERROR every time.

I’m using firmware 01.02.16

I cannot believe how difficult the “auto” install is… what is the point of it being “auto” if I have to manuall find files?

Anyway, I only have a few days to return so if I can’t figure this out by Wed I’m returning this POS for another apple product.

Thanks for any help.

What version of the installer are you using? The current one supports patching 01.02.16, but older ones (from before the release of 01.02.16) don’t know how to patch it.

says 1.2.11

Still having alll the same issues.

First it won’t “autodetect” my clip+… I select the drive it’s in (F) then I try hitting the “autodetect” button.   “Could not detect a mountpoint.  Please select a mountpoint”

This to me makes absolutely no sense… I selected the F drive… my clip is F drive.  WTF! SO FRUSTRATING.

So I click “okay” anyway and try clicking “install the bootloader”

I get the same "requires original (BIN) folder.

It would be nice if THEY COULD ELABORATE ON THIS INSTEAD OF TELLING ME TO GO FIND IT ON SANDISK FORUMS!!!  Godawful as far as user friendly goes… and I thought apple was bad. 

WHERE DO I GO FROM HERE!?!?!?

1.2.11 can patch the 01.02.16 firmware file, so if you’re getting an error message saying it can’t recognize the file, its probably because the file you’re giving it isn’t the 01.02.16 firmware file. Can you double check what exactly you’ve fed the installer? Edit: by any chance does your “bin file” actually end in “zip”? If so, you need to unzip the file first.

Screenshots coming your way

http://i12.photobucket.com/albums/a229/livinglegendlll/Untitled.jpg

WHYYYYYY

What drive letter is your Clip?

Drive F… its all right there in that screen shot… apparently we can’t post pics on this site:cry: 

http://i12.photobucket.com/albums/a229/livinglegendlll/Untitled.jpg

Please let me know what other info you need.  I need to get this done ASAP because im going on vacation soon.  CAN"T LEAVE WITHOUT MY MUZAK

No, I mean what drive letter does Windows report that your clip has?

http://s12.photobucket.com/albums/a229/livinglegendlll/?action=view&current=Untitledsdfg.jpg

Here’s the other window I get when trying to install bootloader

*sigh* It’s drive F

@mcfatterson wrote:

*sigh* It’s drive F

Hmm, and you’re sure thats not the SD card? Is it writeable? What happens when you try and copy a non-music file (like an exe or zip) to it?

http://s12.photobucket.com/albums/a229/livinglegendlll/?action=view&current=Untitledfghfgbb.jpg

^See drive F

@mcfatterson wrote:

http://s12.photobucket.com/albums/a229/livinglegendlll/?action=view&current=Untitledsdfg.jpg

Here’s the other window I get when trying to install bootloader

What happens when you follow those instructions?

http://i12.photobucket.com/albums/a229/livinglegendlll/Untitleddfgdfvfvdfgfg.jpg

^I GET THIS…left side.

God I hate sandisk + rockbox.  Total waste of life right now.:angry:

According to that error message, I think you tried to flash the rockbox manual to your player. That would destroy your mp3 player, so the utility is refusing to let you do it. Instead, when the message pops up click on the wiki link, and then download the original sandisk firmware (or alternatively just download them from this message board directly).

Please keep in mind I am a n00b.  I dont quite understand a lot of what is on that page.

What about the ‘bootloader’ right next to “original firmware”

Do I do anything with that?  I still cannot get passed this guy >

http://i12.photobucket.com/albums/a229/livinglegendlll/Untitled.jpg

^

What is up with that?

Am downloading the original firmware now,  I just drag it into the player correct?  i dont have to unzip or anything?

Would be nice if there was a n00b friendly solution.  There is no way I could see the majority of people doing this correctly the way it’s setup.

Still curious if you can copy files to the player normally in Windows? Other then that I’m not sure what else to try.

http://i12.photobucket.com/albums/a229/livinglegendlll/Untitledsdfsadfcccccccc.jpg

Got the BIN taken care of (went to the wiki page and downloaded the original firmware, I then extracted the files and found the 1 that had the .bin at the end and selected that 1 when it asked me to select the file)… I just hit OK and the window just goes away… I assume I now move onto the Rockbox portion?

When I first got the player I took it out of it’s crappy box (reminds me of Curb your enthusiasm) and plugged it in.  I was able to start dropping music files in without a problem.  I tried comparing it to my iphone 4 and it doesnt sound nearly as good (despite the reviews I read).  Hopefully rockbox will change that.