How to format 32GB SanDisk Cruzer

I was unable to access files on my Cruzer.

Worked fine for a day or so.

When I plug it in, I get a message that it needs to be formatted

I attempted to reformat it and find that I cannot.

The utility that pops up fails each time.

Anybody have any suggestions?

1 Like

Sounds like you yanked it out without doing a Safe Removal.

And without knowing what OS your using, how you attempted to format it, what told you that you can’t and what utility pops up there’s really no way to diagnose your problem or offer specific advice.

Windows has the necessary function for formating drives so use that.

I’m using Windows 7, 64 Bit. The Windows format utility fails each time I have tried it.

1 Like

The steps in this thread help?

http://forums.sandisk.com/t5/Cruzer-flash-drives-Solid-State/i-might-have-destroyed-my-4gb-flash-drive/td-p/235732

No, I had spotted that one and tried it but it did not work for me.

It shows the entire space as allocated (no unallocated space), thus no ability to select “New Volume”.

The disk management program shows:

Layout 0 Simple

Type - Basic

Status - (Healthy (Primary Partition)

29.82 GB

Correction:

It shows

It shows the entire space as allocated (no unallocated space), thus no ability to select “New Volume”.

The disk management program shows:

Layout - Simple

Type - Basic

File System - RAW

Status - Healthy (Primary Partition)

29.82 GB

And when you select the RAW volume FORMAT is not an option?

I am able to select format. I selected Quick Format. I get a message that it is formatting.

Then I get a message a few minutes later that “the format did not complete successfully”.

Tried unchecking the Quick Format box and doing it again.

Says it is formatting but nothing happens, even after waiting several hours.

So, unfortunately I am still on stuck.

Dave

Not sure why the format option isn’t working directly but at this point I would delete the USB partition, reallocate it, and reformat it.

Is there a utility to do this? Unsure how to go about this.

Dave

I was going to say Windows’ Disk Management but I just tried that and see what you’re saying. :dizzy_face:

I am not aware of an alternate Windows utility to manipulate USB volumes.  At this point I suggest booting a Live Linux CD and see if it can delete or format the USB drive.  Parted Magic would be a good one to try:  http://partedmagic.com/doku.php?id=downloads

hmmmm  The recent last posting on this thread sounds interesting.  It can’t hurt to try.

http://forums.sandisk.com/t5/Cruzer-flash-drives-Solid-State/Not-able-to-open-Sandisk-Cruzer-8GB-Pendirve/td-p/230598

Ed:

Thanks for all you patience and efforts in trying to help me!

Tried the steps in the thread you mentioned. It was a no-go.

I am a real zero at this stuff.

I don’t think it is a defective Cruzer as it worked fine out of the package.

I had put about 26GB of data on it and was able to retrieve files from it with no problems.

I had decided to delete a few files from it. That is when my problems began.

I am thinking I probably just deleted something I should not have, thus disabling it somehow.

I am thinking to just call it a day on this new Cruzer and turn it into a keyfob or something!

Dave

Hi DavidM,

Try to format it with memory stick formatting tool like Memory Stick Formatter,Any Drive Formatter.

Have a nice day!

Byan

Hi,

Formatting your memory card, flash drive or device:

  1. Double-click My Computer, or Computer (for Vista)

  2. Right-click the drive letter associated with your memory card, flash drive or device, then select Format
    (in the sample image below, we right-clicked on H:)

WARNING: Make sure you select the correct drive letter.

  1. Select a File system type.

NOTE: Select FAT32 for 4GB or higher capacities. FAT for 2GB or lower capacities

  1. Click Start.

Hope this information helps you.

Thanks, but fails every time…

Dave

Try Ryan’s app linked to at the end of this thread:  http://forums.sandisk.com/t5/Cruzer-flash-drives-Solid-State/Unable-to-format-16GB/m-p/248594#M1629

hai sandisk 4gb format tools

i cant format. no FAT32. size of disk 10mb instead of 4gb

Had same issue.

You need this: http://download.cnet.com/EaseUS-Partition-Master-Free-Edition/3001-2248_4-10863346.html?spi=1afaa809998645ebbf7377a285b0599b&dlm=0

Delete all of the partitions, then create a new partition, done in 30 seconds.

Enjoy!

Delete all of the partitions,”

psssst  There’s only one partition on flash drives.  Pass it on.