i might have destroyed my 4gb flash drive ??

here is what i did, and my 4gb sandisk flash drive will no longer work, although it is recognized by pc. upon inserting into pc it tells me to reformat before use, but when i try to it says it cannot

  1. opened command prompt (running win7 x64)

  2. drivepart [enter]

  3. list disk [enter]

  4. select disk 1 (which is my flash drive) [enter]

  5. clean [enter]

and thats it i got a message that it couldnt be cleaned and now when i pull up the properties of the flash drive it says:

used space- 0 bytes

free space- 0 bytes

the whole pie chart is blue which represents used space.

is my drive ruined or is there a way to fix it. i dont care about recovering any data i keep it backed up on external driveS i just want it to work again :slight_smile: thanks in advance for any help

I did the same thing with same system (win7 x64 but 8gb drive)  I “cleaned” it too.

Right click computer >manage>storage>disk management

You should see the drive with unallocated space.

Right click the space, select “new volume”

Run through the wizard but do *not* format at this step.  

When a new volume is created, it will ask if you want to format.

Format at this time.

1 Like

I have done the same step last night. I don’t think there is a difference between Windows 7 running 32-bit with 64-bit. I haven’t encountered this problem. However, I don’t really sure if that’s the cause of it.

Sandisk thumb drives are pretty tough, so I doubt it.  What can happen is you “wipe” the drive by pulling it without properly unmounting it.

Sorry to say, whatever you had on there is gone, but the drive will likely still work.

Re-Formatting from Windows Explorer may not be allowed, and if not, you have to do this from the MS Disk Management MSC (under WinXP, sp3).  This may be different under WinVista, Win7 or Win8, but the same general procedure will apply.

Right-click “My Computer”; pick “manage”

From the Left hand side of the Computer Management console, pick “Disk Management” 

On the Right hand side, scroll down to find the drive, you will see it is “unallocated”  You have to create a partition, and then format it. 

Your Sandisk Thumbdrive is now ready for action again.  Hope this helps.

I tried levierra’s suggestion, but I don’t see anything labeled “unallocated space” . I see  “new Volume” when I select format from the right click…  I’m in DIsk Management, see my drive letter, indicated as FATAL (which is what I want) and the only description is "healthy (active). Then I get a notice that the format attempt failed.  I’m running XP SP3.  I have tried both the suggestions on the SanDIsk website to format the card, but neither of them worked.  Any other suggestions, or do I go get a new card?

Just wanted to say I had tried to “quick format” and got nowhere, so I tried to do a full format. It got to 99% and then failed…

Incidentally, spell check goofed me up… Earlier message should have read FAT 32 not FATAL…

Anyway, I have no other tricks in my quiver…


Hello Ed… Thanks for the info.  I am extremely happy to report that the replacement card has been received and it was covered by the warranty… whichh, to be totally honest, I didn’t know was still in effect. It’s nice to do business with a company that treats its customers so well.


the dok

And it’s nice to receive feedback like your’s.  Thank you dok.