SanDisk Cruzer Blade 32GB Formatting Problem

I have a SanDisk Cruzer Blade of 32GB, i cannot format it.

it’s currently showing “Unallocated” with 31.25GB, so i tried to “Create Partition” and “format”, but it takes forever to do that, and sometimes it’s ending with “operation timeout”.

So it is stuck at creating a primary partition, i tried using Diskpart and many formatting tools including low-level formatting tools. all takes forever. also tried GParted CD to create the partition. same thing.

When i view the specifications in ChipGenius it’s not showing any SanDisk related lables.
it shows “USB Mass Storage Device(Generic Flash-Disk)”.

I remember i did use a formatting tool then that issue occurred. so i’m guessing the drive had have an incorrect software info like PID/VID, but its still showing 32GB in windows Disk Managment.

I’ve searched the entire web for a utility or a software/firmware for that drive, found nothing.

Any chances to save this usb drive?

ChipGenius specifications:

Description: (G:)USB Mass Storage Device(Generic Flash-Disk)
Device Type: Mass Storage Device

Protocal Version: USB 2.00
Current Speed: High Speed
Max Current: 500mA

USB Device ID: VID = 1908 PID = 1320
Serial Number: **********

Device Vendor: Generic
Device Name: Mass storage
Device Revision: 0001

Manufacturer: Generic
Product Model: Flash-Disk
Product Revision: 1.08

Controller Vendor: BW

It doesn’t sound like you can save it. Better to just return it for a free replacement.

If you want to try one last format try this RMPrepUSB posting may help.