How I debricked my Sansa Express

Hi everyone,

Yesterday, I tried updating my Sansa Express’s firmware to 01.01.05 and guess what happened…  Upon finishing the update, I tried turning the device on and all that happened was the SanDisk logo appeared for a moment and then the screen went blank.  Soft-resetting the device didn’t help.

I reconnected the device to my computer and saw the two drives (for internal and external memory) after switching to MSC mode.  There was also a small blue object in the middle of the device’s screen (like a 2D barcode).  I clicked on both drives, but Windows Explorer said “Please insert a disk in drive [X:].”  I tried formatting the drive for the internal memory, but it didn’t work.  Oddly enough, the firmware update utility was still open, so I ran it again.  It said the device would need to be formatted, so I clicked the appropriate button to proceed, but then it came back with an error.

I was thinking I would have to send the device back to SanDisk, but then I tried soft-resetting it while it was connected to my computer.  <Edit>Actually, I did something else; see my next post.</Edit>  After doing this, a “Found new hardware” window appeared and my computer said it had found an STMP3600.  After selecting “Yes, this time only” and “Install the software automatically”, my computer said it had installed a “Player Recovery Class”.  I tried running the firmware update utility (which was still open) again.  It said it would have to format or erase the device, but this time it worked!

Now my device is operational and has the latest firmware.  Fortunately, I keep a copy of the device’s Music folder on my PC, so copying back my music wasn’t a problem.  (I don’t have any music crippled by DRM.)

If your device is currently bricked, I hope this information helps you fix it.  If you have closed the firmware update utility, you may have trouble getting it to reopen.  In this case, I would suggest reading this thread and using the utility it refers to.  If you have the same problem as I did, you may have to skip steps 2-6, which appear to involve mounting the device in MSC mode.

Thomas

Message Edited by Thomas on 12-28-2007 09:06 AM

Note - November 18, 2008:  Those of you who just want to fix your device without reading through over 100 messages, please see this post.  It says where to obtain the latest firmware and describes what is probably the best procedure to follow.

Message Edited by Thomas on 11-18-2008 02:47 PM

Thank you thank you thank you!! I fixed mine like this aswell. I was sure it’s dead becouse no one on this forum sugested anything that worked for me. Anythingbutipod.com didn’t know what to do also. I performed the steps you suggested.
2 things:
1.[quote]I was thinking I would have to send the device back to SanDisk, but then I tried soft-resetting it while it was connected to my computer.  After doing this, a “Found new hardware” window appeared and my computer said it had found an STMP3600.[/quote]
You didn’t do this by soft reseteng. This is done by pluging the sansa to the comp while holding the (-)volume button. Maybe you’ve done this by accident…
2. The installation of the “Player Recovery Class” didn’t work for me becouse it simply didn’t install anything and I had no clue what player recovery device class means so I googled it. Then I figured that you had drivers on your comp that mine was missing (are you using Vista? Do you have other players software installed on your comp?).

 So I googled for more info on the STMP3600 chip and found that the problem is not only with the SE player but with many other players that use the same chip. Like this one http://forums.cnet.com/5208-6035_102-0.html?forumID=71&threadID=266906&messageID=2601264
from the posts in there I figured that i need to download a firmware update tool for a different player that uses that sigmatel chip.
So i downloaded from here http://www.maxfield.de/index.php?id=21&tx_maxproductslist_pi1[pro_uid]=127&L=1&no_cache=1
Installed it and I guess the Player recovery class was installed with it.
Now after pluging the player in STMP3600 mode I was able to install driver for it.
Then I oppened the Sansa updater using this download you suggested http://forums.sandisk.com/sansa/board/message?board.id=express&thread.id=1143
And now it worked. It was able to reformat the SE and installed the firmware on it.

So it works like a charm now. Thanks.

EDIT: I uploaded the latest firmware here http://www.megafileupload.com/en/file/32366/SE-rar.html so you don’t have to use the old one when fixing the lil’ monsta

Message Edited by Peyotero on 12-28-2007 05:51 AM

I’m glad I helped you fix your device.  You were right about holding down the Volume Down (-) button while connecting the device to your computer.  I had wondered why I couldn’t repeat the procedure by doing another soft-reset while connected.  After seeing your post, I tried holding down the Volume Down (-) button while connecting the device to my computer and I got it recognized as an STMP3600 again.

To get the “Player Recovery Class” driver, I let Windows XP’s “Found New Hardware” wizard connect to the Internet and find the driver automatically.  Unless you are using an older version of Windows, you probably could have done the same thing.

To summarize, here is the revised debricking procedure:

(1)  While holding down the Volume Down (-) button, connect the device to your computer.

(2)  If a “Found New Hardware” window appears for an STMP3600, let Windows connect to the Internet to find the “Player Recovery Class” driver automatically.  If you can’t do this, obtain the tool mentioned in Peyotero’s post and repeat step (1).

(3)  Run the firmware update utility for the Sansa Express.

I have just one thing to say to you guys. Thank you. :smileyvery-happy:

I followed Thomas example above, actually I followed and tested it for several times. It worked out just fine. I have been reding almost every post on this forum and after about six or seven hours of manipulating the SE it finally worked.

I bought it for my mother for christmas so I felt obligated to fix it when it crashed. She was in the betatest-period of the player and it just stopped working.

I am certain that I must do this soon again. I’ve bookmarked this section.

Again, thank you.

(system: Vista 32)

Peyotero wrote:

1. I was thinking I would have to send the device back to SanDisk, but then I tried soft-resetting it while it was connected to my computer.  After doing this, a “Found new hardware” window appeared and my computer said it had found an STMP3600.
You didn’t do this by soft reseteng. This is done by pluging the sansa to the comp while holding the (-)volume button. Maybe you’ve done this by accident…

 


On my supervision: do not release the (-)volume button there will be no yet a message " Found New Hardware ".

I tried everything here and it still doesn’t work. Also, it doesn’t make any sense to have to try all these gymnastic. What happened to plug & play? I thought it was supposed to just work. Come on! Does anyone at SanDisk ever test their products? I’m getting an ipod. You get what you pay for, folks. I tried a cheap player, and that’s what I got. By the way, I’m pretty sure this post will be deleted…

i got my express debricked, thanks Peyotero and thomas

i was so close to returning this piece of crap

guess how it bricked: the express wasnt building the mp3 database correctly (unknown artist/album) so i must have resetted 4 or 5 times to make it rebuild, then it bricked

Hello Guys,

I checked out the information. That is true, the root cause is the chipset. I was too able to recover via the tactics presented here.

It is sad that for such a known problem Sansa does not publish a precise and thourough application note.

Hope they read that the people struggle so much ( and find their own solutions anyway :) )

To make it more clear for the followers, keep pressing (-) button of the player until the full action is completed (windows auto recognition and then firmware update process). Be aware it takes some time depending on your system and do not hurry. Once it is done, you will have your above average player working again.

Thanks for the feedback and have a nice year!,

Kadir Gokhan Simsek

:cry:

help
help
hey i have firmware 01.01.05p is it ok or do i need to download a new one
because i too had the same problem and have got it repaired twice from sansa service centre

Thank you very much for this recover information. The recovery mode may be in the manual, but it isn’t very clear how it works. As for firmware, localization shouldn’t matter, nor version. It will restore the current version, even if is the same as already on it, and format the device. On my player, I deleted all songs using windows explorer, then dumped a large folder of songs onto it. Seeing no obvious activity and being in a hurry, I closed the explorer window and unplugged my Express. It went through the “updating” thing, then shut off and wouldn’t go back on. Note: I think that the method of plugging in a memory card would work too. My device powered up, but the “disk drive” of the internal memory was corrupted. It had to be reformatted. A memory card would give it a good memory device to work with, and let me pull that off. But I didn’t have one, and not everyone will get one just to fix the player. Still, the method isn’t obvious. Also, for anyone without high speed internet, the process is painful (I was away from home, trying to use my laptop to access it, and couldn’t – it might have worked, given a few hours to run).

Hi Thomas,

I just wanted to say thank you for taking the time to write this post. I used it to “de-brick” my Sansa Express when it did not turn on, and it saved me from the incompetent technical support that for some reason told me that this problem couldn’t be solved except by returning the device to them. It’s unlikely that I’ll ever buy another Sandisk product because of this experience, but I did want to say that your efforts and post saved me time finding a replacement MP3 player, and I very much appreciate that.

Thanks again!

Many people do not have any problems with formating, installing latest firmware, using bigger microSD cards and so on…

Is it possible that this is a manufacturing fault with certain batches of SEs ?!

I suppose hardware problems could be to blame for some of the trouble, but personally, I suspect all of my problems were/are software issues.

Its actually not that uncommon for reputable brand-name manufacturers (like SanDisk, HP, and Adaptec) to release products with poor software.  I suppose they want to release the product as soon as possible and they figure they can always release patches a few weeks/months later.  (Sometimes the patches are never released…)

I’m glad I was able to help some of you fix your players.  Hopefully SanDisk will get their act together and release a decent firmware for this device.  SanDisk makes good memory cards and USB flash drives, but I think someone in their Sansa division deserves to be fired.

How are you opening the firmware updater?

mine only opens when I plug the player in as normal, when I’m in Recovery Mode it doesn’t open, Ive gone into the programs file folder but it causes an error when I try to open it that way, saying “Sansa Updater can only be launched by Sansa Service!”
Ive tried searching my computer for “Sansa Service” but didn’t find anything.

Try using the updater mentioned in this post:

http://forums.sandisk.com/sansa/board/message?board.id=express&thread.id=1143

The instructions in this post actually describe putting the device into recovery mode, but step 5 is misleading as the STMP3600 does not connect with a drive letter (at least not on my computer).

I had to make another account as I didn’t save my password and I use disposable email addresses.

After writting that message last night I used that updater and not only did it work but it gave me fm radio and it works :wink:

So thanks alot SanDisk, Thomas and Peyotero, I now have a perfect working mp3 player with fm radio and recorder and it only cost £25 :D.

I was under the impression before that its cheaper to leave the radio chips in than remove them, the reason Europe has a non radio version is you have to either pay more tax or vat on products that can access radio, also the volume is louder and I’m pretty sure thats because in Europe theres a health and safety law that says audio devices have to be under a certain amount of decibels to prevent damage.

I’m glad you got your player working and that you now have FM radio.  But don’t damage your hearing with it…  :smiley:

There actually aren’t any separate radio chips because the FM tuner is built into the SigmaTel STMP3600 system-on-a-chip that runs the device.  It is neat that SigmaTel managed to fit so much hardware onto a single chip.

lol I actually have very good hearing :slight_smile:

I presumed the chip was separate and that it may have had this chip “Philips TEA5756 Low Power FM Tuner Chip”

although its normally found in unbranded players, I wonder why more people from Europe aren’t flashing theres with the American firmware.

Do you know what format the startup logo is in?  I was thinking about trying to make a program that allowed users to set there own startup logo.

It shouldn’t be that hard once you know the logos format, hex address and size, I was thinking something basic like the user making there logo in mspaint, the program opening the firmware file, replacing the SanDisk logos values with theres and then saving and closing the firmware file and then using the SanDisk flasher to flash it back.

I don’t know what format the logo is in, but I would guess it is some sort of bitmap.  You might be able to find it’s location by taking a picture of the logo, manually recording a line of pixels (or maybe one horizontal line and one vertical line), and then searching the firmware for the corresponding data.  The pixels could be stored as bits, bytes, or even groups of bytes, so you might have to write a program to try the various encoding possibilities.

I am wondering if the firmware files themselves are encrypted or otherwise scrambled.  I just looked at player.sb and player.rsc, but didn’t see any plain text in them.  I would presume that the text for the messages and menu options are stored in ASCII or Unicode.  Do you have any thoughts regarding this?

I’m not sure if that would work for the logo but its definitely something worth trying :slight_smile:

I too looked at the firmware and couldn’t find any text strings, I searched for a few hexadecimal values aswell but none showed up

466f726d6174 = Format
46206f2072206d20612074 = F o r m a t
506c6179 = Play
50206c20612079 = P l a y

I do think the files are encrypted, I done a search and the SanDisk e200 used TEA encryption (Tiny Encryption Algorithm, heres the wiki entry)

I then downloaded a so called TEA decrypter and tryed to decrypt the firmware file, it says it was successful but when I opened the decrypted firmware file in a hex editor the files header had gone, so I think the TEA decrypter damaged the file.

Here was the normal firmware files start (the header)

ÌÌÌÌÌÌÌÌÌÌÌÌÌÌÌÌÌÌÌÌRSRC #

heres the so called decrypted file

;õ ÏòÕæ3÷9Û > *5a‡¶íjè JÛ“(ç>púê

also no text or hexdecimal vaules was found in the claimed decrypted file.

I was thinking if we could get hold of the firmware files for the European version we could then compare the European version with the American version, we know the differences are fm radio, recording radio, louder volume and a couple of extra options relating to them things, so the firmware should nearly be the same baring a few things, we could then get all the differences and try decrypting them and maybe find out that way what the firmware is encrypted with, since we know we should atleast see the term “FM Radio”.

I’m going to carry on searching for the Europe firmware files, if I find them I’ll post a link here.