How I debricked my Sansa Express

Using the Sansa Updater, you should be able to change your firmware region to PacRim/Asia or Japan.  When you do this, the different firmware files will probably be placed somewhere on your computer.  You can’t change from America to Europe, however, probably because SanDisk then wouldn’t let you change back.

If you manage to get the European firmware, I wouldn’t count on it not containing the string “FM Radio”.  It’s possible that the firmware still has the code for running the radio, but it is enabled/disabled according to the region.

Where did you obtain your TEA decrypter?  I looked at the Wikipedia article for TEA, and it appears to me that it would take a bit of effort to decrypt something without the encryption key.

Another idea:  If you can’t decrypt the firmware files, maybe you could connect the player in recovery mode and get the STMP3600 to dump its firmware, if it will do that.

Unfortunately, I don’t have a lot of spare time to work on this.  I just bought this device to play music and record from the radio, not to hack it.  If you have lots of spare time, perhaps you could work on a Rockbox port for it.  This would be really great to have considering that SanDisk’s firmware is somewhat buggy and unstable.

I know you have received lots of thanks, but I have to join the chorus.   After reading all of the forums I am amazed that there is such a big problem with the SE and that Sandisk has not done anything to address it is a serious way.  All of the suggestions here helped me a great deal.  My SE works fine again.  You guys are great!  Thanks again.

Hi Guys,

I had the same problem and thought it was a dead battery so my SE’s been sitting on the shelf for months.

This fix worked flawlessly and now I’m rockin’ to my tunes.

This fix should probably be added to the manual, FAQ’s and submitted to tech support.

If I could give you a friggin’ medal, I would.

This information linked to that thread from Jake worked for me. And it was the only thing that worked. Thanks all. :smiley:

For AMERICAS - You can download the .zip file by clicking on this link. ; *only American version is currently available.

  1. Unzip the files into a folder on your desktop.
  2. You’ll see a file called “StMp3Rec.sys”, move this to "C:\windows\system32\drivers". If you already have this driver, no need to overwrite the files. You should also see another folder, this is the firmware update folder.

Back up everything that’s on your device. The firmware update may delete your files!
3. Press and hold the (-) volume button while plugging in device to PC. This took me a couple of tries, but eventually it connects with a drive letter instead of the “Sansa Express”.
4. If there’s message asking to install driver, choose “Yes, one time only” and follow the steps to complete driver installation. You should already have the driver as it is included in the zip, but it doesn’t hurt to verify.
5. Now, open up the firmware folder and double click on “SansaExpressUpdater.exe”.
6. A message will appear informing you that updating this firmware will erase everything on your device. 

If you have not backed up your data, then please do so, or you’ll be sorry! Once backed up, proceed with the update process.
7. Once the update is completed, click on “Finish” and wait for 2 seconds before unpluging your Sansa Express from the computer. This ensures it is updated completely.
8. Now, you’ve completed updating your device. 


Message Edited by JMac on 02-14-2008 02:18 AM

Those are good instructions also.  But I think step 3 is misleading because the device does not connect with a drive letter (at least not on my computer).  Instead, it appears as an STMP3600 “Player Recovery Class” in Device Manager.

Was your experience different?  What version of Windows are you using?  (I’m using Windows XP Service Pack 2.)

You could very well be correct Thomas. After multiple attempts with every other remedy I can’t recall for sure. But I do remember the "STMP3600 “Player Recovery Class” in the device manager. Very strange how it would continually hunt, find, and then lose the SE. And it had an very strange, adverse affect on my OS (Windows XP Service Pack 3 ver. 3244) while the SE was interfaced. All I know at this point is that it worked friend.



I have tried following the debrick process, but I cannot get the drivers installed.  I put the StMp33Rec.sys file in the windows/system32/drivers directory, and the STMP3600 will not get loaded.  This short circuits whole debrick process.

WinXP is looking for .inf files for installing drivers, and I’ve tried letting it look everywhere.  I followed a couple of the links in the thread looking for additional driver files but no luck.

I’d love to debrick my 11-year-old daughter’s Christmas present so she will once more have access to her tunes on the road.  if someone can help me get over this obstacle so I can debrick the device, I will be forever grateful.


Have you tried letting your computer connect to the Internet to find the driver?  If you connect the device while holding down the Volume Down (-) button, a “Found New Hardware” window should appear for an STMP3600.  If you let Windows connect to the Internet to find the driver, it should automatically load the “Player Recovery Class” driver. Then you can run the firmware update utility.

I’ve let it look through the CD, the entire computer, and I assume it’s looking on the Internet (I’ve never set any permissions to preclude that option).  What I get is the “Cannot Install This Hardware” error message (cannot find the necessary software).  I didn’t think I was that dense, but I must be missing something.


After your computer fails to find a driver, try going into Device Manager, right-clicking on the STMP3600, and then clicking “Update Driver” or whatever.  If I do this with an ordinary device on my computer, a wizard appears with the first screen asking if Windows can connect to Windows Update to search for software.

Did it and allowed it to go to Windows Update - no dice.  Naturally, the STMP3600 is showing up in Device Manager, albeit with the unrecognized ‘!’ because there has not been a driver installed.  I don’t know how to force it to find the driver any other way.  Has somebody posted the driver somewhere besides the MegaSite location that is not there any longer?


Sorry.  I don’t know what else to try.

I would suggest using a different computer.


My business partner happened to be here with her laptop.  Tried it and got PRC loaded.  My daughter will be so happy when I pick her up from school this afternoon!  I’m thrilled!!


So, I was fiddling with my girlfriend’s new Sansa Express, which had gone exactly the same way. Even tried mounting it in Linux, but NOTHING seemed to work. Tried using the “recovery mode” (Volume - and Hold) and plugging it in, only to fail to install the STMP3600 driver needed for recovery mode, whereupon I tried finding a good solution, until today, when I found another device driver package that included the STMP3600 driver needed.

Having read about everybody’s problems here, I figured I’d put together the Sansa Express Rescue Kit. :wink:

It includes the STMP3600 drivers, found in appropriate folder - when your computer asks for the driver, just choose to install the driver yourself, and point the installer to the driver directory I included. I’m not sure if all the files in that folder are needed, I felt I’d better include them, just in case.

The .zip also includes a folder complete with the Sansa Update I used for restoring the system. Not sure if it’s the latest version, but it did work for me.

So - first connect your player (in recovery mode of course) and install the STMP3600 -> then use the updater. Should be fixed!

As for the file -

I hope this will help someone, and that I’m not violating any restrictions by posting this .zip, if so, feel free to remove it!

Message Edited by sorrowbynature on 03-18-2008 06:07 AM

Help!..lmao …that seems to be a very common word upon these forums… Im having the same problem as most…The logo comes on for 2 secs and then bam.Nothing…and when I try to turn it on again it bricks it self up ( like it wont turn off or anything) …The Advice to hard reset it when it bricks up works .But then I’m still stuck with the logo and not turning on problem … Yeah …am I just crazy or is there a way to stop it .Oh and before u ask …yes I tried the (-) volume down button while plugged in thing.It doesn’t do anything…:cry: help me plz! lol

Have you followed the procedure exactly?  You have to be holding down the Volume Down (-) button as you connect the device to your computer.  Some people have said that it may take a few tries before it works.

Trying performing a soft-reset (Volume Up + Select) right before doing this.  This should ensure that the device is powered off (and not in a locked-up state) upon connection.

My express has just (last day) died on me so ive started reading up on this, having some trouble though i cant connect the device as MSC, ive tried holding down the volume - button even after a soft reset, the device shows up as the player recovery class in device manager but the updater keeps telling me im in the wrong mode (although it says this even with no device attached!)

so what can i do? my player isnt that old and was a christmas present from my GF i dont really want to bin it!

I am fairly confident that your player is recoverable.  Recovery mode vs. normal mode and MSC vs. MTP are completely different things.  MSC vs. MTP refers to how music is copied to the player.  (MSC treats the device as a standard USB flash drive, whereas MTP (Music Transfer Protocol) involves Windows Media Player and the DRM ■■■■.)  Recovery mode is only for reflashing the player after its software gets too messed up to restore itself gracefully.

I think there is something screwy with the updater.  I have my computer set to recognize my Sansa Express in MSC mode.  When I tell Sansa Updater to check for updates, it tells me that the device is connected in MTP mode and can only be updated in MSC mode.  (This despite the fact that it is in MSC mode.)  I think I’ve seen the opposite message as well (you’re connected in MSC but need to be in MTP…).

I suggest that you keep fiddling around with the updater.  Try stuff like restarting your computer, and uninstalling and reinstalling the updater.  Try using a different computer if available.  You’re on the right track.

 This are refering to "Peyotero"s instruction on page 1 post 2 in this thread (im failing to quote)

I don’t think my English is skilled enough to see on my own after if it has arrived a solution-answer on this 4 pages thath i can take an apply directley to my problem

I holded down (-)volume button while pluggin in the player, computer found a STMP3600 hardware, “install automaticly” difference is thath i didnt even get any message or the like about missing “Player Recovery Class” after it failed the installation (perhaps its just a word you use by your knowlegede?)

 (I dont have Vista i dont have any other players soft installed)

Nethertheless your have the most similar issue so i keept going, to here[pro_uid]=127&L=1&no_cache=1

but your link doesnt go directley to thath models software updater…so i clicked “downloads” myself :wink:

but there i cant find any firmware updater either…but i found it’s latest firmware update only

 I gived up and started Sansa updater instead just to check, and no surprice latest driver are still installed, and if found nothing new to install or erase

So to summ it up

  1. How should i found this softupdater you are refering to?

  2. Is there perhaps allready another solution on this pages thath i have missed to fix the issue thath STMP3600 doesnt auto-install in Windows guide “New device” (or what its now called in English)

Message Edited by Kloppstock on 03-30-2008 03:06 AM

Try using this file that sorrowbynature made:

This file includes the drivers that are needed to recognize the STMP3600 as a Player Recovery Class.