Hmm... Should my movie files be .avi?

Hello Sansa Community (again!),

One more problem… (im not that smart when it comes to computers, so, most of my problems will be easy to solve…)

When I converted my media (a video, which by the way converted easily, once I figured out how to do it…) using  Sansa Media Converter 4 (the newest one), it told me that instead of having it as a .mp4 file (which is what is was, after I converted it to .mp4 from .vob, via All-Media-Converter), I should have it as a .avi file. Now, this avi file appears in my Sansa Fuze (If I am searching for files when it is connected to my computer, and whatnot), with a .thm file next to it (same name and stuff).

Now, after dissconnecting my Sansa Fuze, I tried to see if I could view the video, but I can’t, all it does is appear as “[Empty]”, on my File list for Videos.

So, my question(s) to you is:

Should my Video file be in an .avi format (with a .thm file with it, as well)? If so, why can’t I wiew my videos, and how could I fix it? If it shouldn’t be .avi, what file type do I need to convert it to, and how do I do this (because I can’t choose what file type I need to convert it to, if I use S.M.C.4)?

Thanks again for all your help, in advance!

let me see if I understand…

You have an .avi file, converted using AVC.

You plug in your Fuze.

You open to SMC

You click on Fuze or card.

You open the .avi file and it places it in SMC.

Then you click on the convert button (maybe the file if it’s not highlighted).

When done, disconnect your fuze and check the Video.

The file will not convert to the fuze?

Are you trying to save the SMC converted videos to my computer and then put them on your fuze because you can’t (I tried).

If that’s not what you’re doing, please let us know exactly the steps…

And yes in mycomputer you will have a .thm file next to it (or below).  For some reason there are two.

Everything is fine. Its easiest to look at it like this. AVI as a file extention is like a box, and in that box can be any number of file types, in this case mpeg4. If you found a solution that works then just stick with that.

Well, that is pretty much how I did it, Dalaug, but the only thing im not doing, is saving it to “My Computer”, instead, im saving it directly to the “VIDEO” folder in my sansa fuze!

Anyways, I will state my steps I am using…:

  1. I connect my Fuze to my computer (IN MSC mode) - The computer recognises it is there, so does Sansa Media Converter, and so does the Fuze itself

  2. I go into Media Converter, I find the file, tell it to save DIERECTLY TO MY SANSA FUZE “VIDEO” SECTION, and I convert it (from .vob into .avi

  3. The conversion finishes, I disconnect my Sansa fuze, it “updates” itself, and I search for the file

  4. I look for my file, and it isn’t there, despite the fact that when under “MY COMPUTER”, the file is there on my fuze


Now, there is something else that is happening, that may help figure this out......

Just recently, I have realised that when connecting to my computer (in MSC mode), that my computer recognises that the Sansa Fuze is there, and my fuze says "Connected" (and "Writing", "Reading", etc...), but..... IT WON'T CHARGE, and it WON'T UPDATE MY FILES (like album, song, artist names, etc...), and if I add a file (picture, video, music, or whatever) to my fuze, my fuze will not say "updating", and my files are not there in my Fuze, so now it isn't just my videos, its my pictures and music......

So, my real question should be:

Where is the problem coming from....

If it is my computer, should I replace the "USB port"?

Or, is it my USB 2.0 cable for my Fuze, in which case I may have to buy a new one?

Or, is it my Fuze itself, in which case I may need to buy a new one as well!?

Thanks again for helping, everyone......

Sound like you are trying to use the Media Converter application.  This is different software from the Sansa Media Converter.  

There is an application called “Media Converter” that does conversions similar to AnyVideoConverter.  Actually, a little searching will reveal many variations on the popular theme.

Here is SMC version 4.256  The Sansa Media Converter is from InterVideo.

Updated!  The Sansa Media Converter transfers your video to the Sansa, with the correct “container” for playback on the device.  Downloading the SMC has been changed: it is ONLY available through the Sansa Updater application.  Once you install the Sansa Updater, plug in your Fuze, then open the Sansa Updater (if it does not do so automatically).

To open the Updater, go to  Start > All Programs > SanDisk > Sansa Updater.  Allow th application to open and find updates for your Fuze.  This may take a minute or so.  There will be a check box for the Sansa Media Converter there.

 

AVI format is fine for transfer to your Sansa, but the SMC application is needed to build the proper “container” for the video file.  The video needs to be transferred to the Sansa using the SMC application.

It’s very slow, but the current Rhapsody 4 release will also do this properly (as imported video), but I prefer SMC for speed.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 01-29-2010 05:47 PM

when i put a file in my fuze andm go to its file and press on it, it says unsupported media format likw wtf i used hypercam 3 to record it so that may be a problem idk 

Videos can ONLY be transferred to the Fuze via one of three methods:

  • The Sansa Media Converter
  • The Rhapsody 4 client, select “import video”
  • Video4Fuze, available via the Fuze forum.

Video must be in the correct “container” for the Fuze to play it.  Drag-and-drop will not work, generally.

Bob :wink: