HELP!!!

I just bought this Sansa Clip for my daughter for Christmas and when I opened it, it had a couple songs on it and the battery was half full. Well, i didn’t mind that so I went ahead and added songs and then i charged it and when it was finished charging i unplugged it and tried turning it on and it gets frozen at the ScanDisk logo. Nothing happens after that. This is the SECOND time this has happened… the first one i exchanged at the store but this is the 2nd one to do this after i’ve finished charging it. Any help would be great since this is a gift.

Thanks

(oh, i’m using a MacBook Pro) if anyone needs this info to help me.

The first thing I would try to do is install  the latest firmware on the device.   Check the instructions on the board for downloading the firmware file and dragging it to the root directory on the Clip.  See if that helps.   Then I would try to reformat the Clip using the Disk Utility program on the Mac -  you should use the DOS formatting option.  

thank you, i will give this a try

I am going through the same experience, also on the second Clip.

When first connected to computer’s USB port (the first one came partially charged, the second was not charged), the Clip showed on the desk-top, while it’s screen showed ‘connected’ and charging graphic animation. After the battery logo showed fully charged, I dragged my mp3 tunes to the ‘Music’ folder of the Clip, dismounted the devise by dragging it to the ‘trash’, then disconnected it from the computer. When turned on everything worked fine, my new music as well as the radio. The clip could be turned on and off without any problem.

The second time the Clip was connected to the computer, the display sequence both on computer and Clip showed up normally, however the battery indicator never showed any increase in charge status. After dismounting and turned back on, only "Sandisk Sansa’ logo showed on the display, all controls were unresponsive, only way to turn off was to press ‘start’ and hold for 15 sec (i.e. reset sequence). Same frozen display showed on restart or when reconnected to computer, though the device no longer showed up on the computer. Similar sequence of events showed up on the replacement Clip!

Previous suggestion to update to latest firmware (01.01.18A, Clip came with 01.01.11A), I have downloaded ‘m300a.bin’ file that cannot be opened on OSX10.4.11, how does one upgrade it? Reformatting with Disk Utility would be possible if the device mount and so be recognized by the computer.

Love the Clip, if only can get it to work as music player and radio! Don’t mind going without playlists, artists etc.

(I hope that you all were able to work matters out.  In the future, you probably will get more people looking at your topic to see if they can help if you list the subject in the thread subject line, rather than just yelling, help.)

Ok…here is something you might want to do…I know you already formatted your device a zillion times already but please do it one more time using the Format option under Settings menu in your device…then restart your computer…then plug in your computer again after restarting to see if it recognizes now…if not…here is one thing you could do…go to this link

http://www.nirsoft.net/utils/usb_devices_view.html

download the USBDeView software and see if the registry has the player in there…select it and delete it and then plug in your PC again to see if it will re-register the device and works…hope this will help.

another generic panic subjects… guess who aint gonna pitch in?

Hi,

I had the EXACT same problem and I too am using a MacBook. It seems there is alot of information on this board, but you have to dig as it is not all in one place. Here is my story and what I did:

My daughter rec’d a Clip for Christmas. I started to charge it using the USB connection on my MacBook. After a little while (don’t know how long) I saw that it was partially charged. I opened the Sansa icon on my desktop and successfully dragged some music into the Clip’s music folder. I ejected the Sansa icon from the desktop and unplugged it from the USB on my computer.

I listened to most of the music and it came over okay.

The next morning, my daughter wanted me to continue charging the Clip. So, I plugged the USB connection into my MacBook and walked away. A little while later, I noticed the SanDisk logo was frozen on the Clip’s screen and there was a error message on my computer screen…something about properly removing the device!!

Then, my Clip was completely frozen. I couldn’t do anything because the SanDisk logo appeared and nothing else. I tried plugging it back into the MacBook, but my computer was not even recognizing it! (I kept thinking, did I plug it in right away?) I couldn’t do the “reset” thing that everyone on here said to do. All I could do was turn it on and stare at the words “SanDisk”. I took it back to the store to exchange it.

So, now I’m on my 2nd Clip. I plugged it back into my MacBook to start charging. Within one hour, I received another ERROR and I noticed the SanDisk logo was frozen on the Clip’s screen and there was a error message on my computer screen…something about properly removing the device. AGAIN! Same as earlier.

After researching it a little bit (I had more time) I was able to fix it . So far so good, but I will definetly keep a backup of all the songs on my computer! Here’s what I did:

On the frozen Clip, move (to lock) the left slider to the Hold position.
Press the center circle and hold it while you plug the USB cord into the laptop and into the Clip.
This should get your MacBook to now recognize the device.
Go into your Disk Utility function (HD -> Applications -> Utilities -> Disk Utility) and click on the Sandisk icon.
Click on the Erase tab…this is going to erase/reformat everything!
Pick the MS-DOS File System (FAT 16) as the format.
Pick Erase again if necessary.
After its reformatted (takes a second), eject it properly and try to power the clip back up. You should be able to get past the frozen Sandisk logo.
Plug it back into the MacBook and it should start to charge again and you should be fine now and copy files again, etc.

What a pain! So I hope it doesn’t happen again!

I hope this helps!

good luck and post back here if you are still having problems!

Thank you it worked for my problem of it locking up!

It seems that this is a Mac problem. Maybe the filesystem on the clip is not completely written? Flash devices have a limited number of writes, so good drivers will cache data to extend the devices life. If you unplug it too soon after unmounting the device, you may end up with a corrupt filesystem. Does Mac notify you when the device is safe to remove? Even so, maybe just leaving it attached an extra 20 seconds will help.

On MS-Windows, the Clip does not act like a regular mass-storage USB device, so it may be a problem with the OS handling this type of device.

Also, if the problem occurs, maybe someone can try plugging it into an MS-Windows system, and see if the Windows drivers can fix it, and maybe give an error message to help identify what’s going on.

last post is 50/50… the first 50% didnt really make sense.  the last 50% doesnt either…a couple terms made sense but not in context …
you can try msc in winxp…

Hey guys,

I had the same problem. I think it is coming from spotlight, trash and FSevents which are background OS X stuff.

How to fix it?

Format your clip from the ‘Settings’ menu.

Disable Spotlight indexing by creating the file ‘.metadata_never_index’ on the root of Clip

Disable trash buy creating the file ‘no_trash’ in .Trashes directory on your clip

Disable FSevents by creating file ‘no_log’ in .fseventsd directory on your Clip.

All above directories should be created atomatically after you open clip in finder.

You can delete trash, spotlight files and FSevent logs before above procedure. 

When I did it my clip started to charge properly and stopped freezing

To conduct above operations you may need to use Terminal. You can always list hidden files and directories, ones that start with dot, by typing ‘ls -a’

to create a file type ‘touch file_name’

to delete directory and file type ‘rm -Rd *’

Good luck,

bla bla

HI ,

I Have sandisk Sansa . I plugged into Macbook , It got frozen, Can u pls help me out

I pressed center button and pluged in , my MAC is not recogizing

Pls help

Thanks