Frozen? clip

After the last battery recharge, the clip is frozen or ? It will only show “SanDisk, sansa” on the screen. I have tried to reset, I’ve tried different computers, different USB plug (my husband has the same clip), nothing happens.

I am not very tech-savvy, so please phrase things simply.

I appreciate any help I can get.

OK, let’s try waking it up by putting the player on hold and then connecting the player to the computer via the USB WHILE pushing and holding the player’s center button down. 

Did that do it?

Possibly (and I’m guessing here), you then may need to reformat the Clip from your computer.  But hopefully, the above will wake the player up and get you back to playability.

Try resetting by holding the power switch in the up/ON position for 15 seconds.  Then, see if it powers up normally. Turn the Clip on by pushing the switch up again momentarily as usual.

The reset function is useful for most glitches or freezes from data problems.

Bob  :smileyvery-happy:

You should upgrade to lastest firmware 01.01.20

good luck