help! (sansa view)

when i try to turn on my sansa view all i get is the screen that says SanDisk and then the screen goes away. Its as if it starts to turn on and then stops. I’ve tried resetting it but it’s not working! please help!

You might have loaded bad file or something. While its off, activate the hold switch and connect it to you PC while holding the left button. Look for the files that you have previously loaded and delete them. If that doesnt work. Format it.

how do you format it?

@mamadvade wrote:
how do you format it?

If it no longer goes to the menu screen and if it’s not recognized by the computer, you can do a force format. While it’s off, activate the hold switch then press and hold the up button or 12oclock wheel. Connect it to your computer and as soon as it turns on, unplug it. It should now ask you if you want to format the device.

oh my gosh!! thank you sooooooooooooooooooooooooooooooooooooom much!!! you’re totally amazing!! :smileyvery-happy:

You’re welcome. Glad it worked :smileyvery-happy:

what if after all that. it wont turn on after u press the up button on the wheel. And the computer is still not reading it. what do i do now? just throw it away and buy another one?

My Sansa View will not play any songs.  Was working fine then just stopped. 

At bottom of screen it scrolls: "Now Playing: Unknown Artist - "

When I connect the Sansa View to my PC, my resident MP3 player can access all the MP3s on the Sansa and can play them.  They just don’t play using the Sansa controls.

Tried Formatting, and no change.  (dumped all the mp3s, as I knew it would).

Does anyone have an idea how to fix?