View - Black Screen/Glowing Scrollwheel not mounting on computer


I have been looking around for a few hours now. I was trying to delete everything from my Sansa View and did a normal Windows format on the 16gb drive. This failed and now my player will no longer turn on properly.

If I power on the player, I get nothing but a black screen and the scrollwheel lights up (and stays lit).

If I plug it into the computer on Windows 7 x64 it tries to install drivers for “Tango Digital Media Platform” which fails, and the player does not show up.

On my Ubuntu 10.10 install, the device shows up as “Bus 006 Device 016: ID 0781:0720 SanDisk Corp. Sansa C200 series in recovery mode” however, I cannot get to any sort of USB drive where I can copy the firmware or anything back on. I have tried instructions for “recovery mode” and “manufacturer mode” but with no luck so far.

I have seen this type of problem around several posts, but have been unable to find any sort of solution.  Is it done for?

Thanks for any help.

Danger, Will Robinson!!

The above blue ring of death thread is for the e200 version 1.  Note, the Sansa View is also a PortalPlayer (NVIDIA) powered device, so recovery is different, the e200tool utility is a different case.  When I get home later, I’l look up the View procedures.

The firmware for the View is also in mi4 format , but there are more files required.  The Tando Digital Media Platform error message you are getting is because the firmware image (the platform) is missing.

Bob  :dizzy_face:

Ah! Thank you neutron_bob!

I had looked through the link given by Tapeworm  as well as several links from the pages

of that thread but was having no luck.

I was slightly confused by some of the instructions there. Now I can guess why…

I look forward to any procedures you have for the View. I shall keep an eye out here.

Thanks for your time, its much appreciated.

Well, since no such procedure had ever been devised at the time of neutron_bob’s post, it’s safe to say the following will be some very useful information :slight_smile:

I just finished putting together a tool, script, and information of how to unbrick a Sansa View from the Blue Ring of Death… *VERY* similar to the e200 procedure (in fact, it’s based on the e200’s “e200tool” code), but there were some hang-ups in the e200tool software that caused it to crash a View - specifically, that the load address for the bootloader changed from 0x10600000 to 0x10F00000 (which would crash the View if it’s loaded there). So I made all the handy dandy changes and made a tool for the world to enjoy… now there shall be no more Blue Ring of Death!

Let me know how it works for you!


Now, how cool is that!!  Great to see you’ve found the difference in the View’s NVIDIA/PortalPlayer platform.  I was nervous about folks trying the basic e200tool code, and bricking the device further.  The View has quite a few little bits in there.

Your anythingbutipod post is outstanding, thank you for sharing your efforts!!

Bob  :smileyvery-happy:

Thanks!! That’s the first response I’ve received about the Viewtool yet… I wonder how many people have used it in the past few days and just been too giddy to reply back about it :wink:

The differences are actually amazingly small… the nVidia GoForce 6100 is practically just a PortalPlayer PP5024 as in the e200 series, just under a different name (since nVidia bought PortalPlayer). It even runs the same code, just in a different address space… and with the help of the Rockbox dev notes on their work on the View, I was able to get the e200tool’s basically unmodified code to run on the View. I just gutted a few unusable functions and hard-coded the new bootloader address into the “recover” function (which is just a shortcut for “e200tool write” and “e200tool run”). Hopefully it helps everyone unshelve their old bricked Views and bring them back to life - I had mine shelved for a whole year before I built up the dedication to “JUST GET IT WORKING ALREADY!” :wink:

My View is now happily running our office’s Hold music from ripped WAV files 24/7, since I long ago replaced my View with my Android phone as an MP3 player… but it’s certainly a lot better use than just sitting in a junk-parts cup waiting for me to find the solution!

This is fantastic!

Thank you, it worked perfectly. Took me two tries to get it right, but I got it now.

I will be sure to keep this around for when I, undoubtedly, manage to break the thing again.

Thank you, FalconFour!  Issue is resolved.