Problems with Sansa e280 (8Gb) - many, many problems!

Hi everyone, I’ve been trying to look for answers to this problem throughout the forums and technical support, but since it appears to have got even worse, I figured I would see if anyone can help me.

My Sansa has been buggy for a while, but finally stopped working and saying “Load image failed” (as many other people have experienced) . I tried downloading the Sansa updater, which installed but then couldnt find any updates, even though my device was connected.

So I tried the manual way and downloaded the firmware myself. At this point I could still go into recovery mode. I transferred the files and disconnected the device. It looked hopeful, like it was installing but then the screen went black and the blue ring remained illuminated. For a looong time.

Now the only thing it responds to is the power button, which when pressed, makes the ring go blue and the screen do nothing. Recovery mode will not work. Is there anything at all I can do? In another post someone suggested that removing the battery could help - thoughts?

Thanks so much for any help

Just to clarify, I have just tried taking the battery out and putting it back in again - which has achieved absolutely nothing. At least that’s one more thing that doesn’t work :slight_smile:

The steps here should work for you as well.

When I do that, my computer makes the noises to indicate that something has been plugged in (and again when I take it out) but nothing shows up on the computer, and all I have on the device is the black screen and blue ring. I’m using Win 7, which is normally pretty solid when it comes to automatically downloading drivers etc.

I’ve tried searching for the right drivers, assuming that perhaps that is the problem, Sansa updater seems to be constanting checking for updates and never finding them, so I’m a little stuck on anything else to try at this point :frowning:

I cannot get the device to do anything other than blue ring: neither recovery nor manufacturing mode work. Is all hope lost?

Is a pretty good last resort option? I have access to a computer already running ubuntu…

Right… after using that website as a guide, I can confirm that my Sansa is well and truly fixed. Back from the dead! Now I understand why people like Linux :wink:

Best of all, it sneaked FM Radio on there - which wasn’t on there to start with!

Thanks for your help Jamieson