Help Needed!

Ok so today a friend gave me a Sansa /express, so i could charge it on my pc, i came home connected  it and waited for it to be recognized but it didnt, so i went to device manager and it said there was an unknown usb device but it could not be installed, i checked the sansa and it was super burning hot, i disconnected it, and tried again but now it dosent even turn on or gets recognized as a usb device?Wtf happened, did it burn inside?what should i do?Thanks for the help

Message Edited by kcgig1 on 08-24-2007 09:56 PM

That’s a new problem.

Anyways, super burning hot should not be a problem since silcone is made to withstand high temperatures (I mean you can leave it in your car and it’ll still work, BUT TRY NOT TO DO IT).

What windows are you running?

Xp Service pack 2, it brand new which adds even more frustration if it wouldnt work on the fisrt day, it could turn on before i tried plugging it into the pc, but after that it dosent even turn on, i dont know if its because it ran out of battery or if its busted.

Maybe an overcharge. There’s been problems posted like this. Trying doing a hard reset.

Hold down volume up and select (center) button more 30+ secs. Then turn it on. If not working then try the hard reset again.

If the second time fails tell me. I’ll be on quite awhile tonight. (I’m bored)

Ok thanks ill try, itried doing that but not for more than 30 secs, i tried for like 5

Guess it worked?

It didnt work, so i think thats it . its busted because when i connect it to the pc, it dosent recognize it any more, like it did before it got really hot.

Most likey a circuitry problem then… (probably a short circuit)

I understand your frustration. I only had mine for one day as well, till the updater failed.

I guess you can call and get it RMA’d

Yea this sucks lol, oh well so much for a new Mp3 player, after seeing it i was thinking of getting one of my own, guess not.

SKyL thanks for all the help, i have good nnews, after trying and trying it finally works i just connected it and it works, now to charge and put music in it, thanks again for the help.