HELP NEEDED...PLEASE?? Multiple Issues with Sansa Fuze & Computer Connection.

Hi All :smiley:

I NEED Some HELP…Pretty Please??? I Have Now Spent Hours Scouring These Forums & Have Come Across Some Similar Issues & Tried the Suggestions Given but Unfortunately to No Avail !! So,…Instead ofWasting More Time in Searching I Thought It Best to Just Come Here & Post MY Particular Issue in Hopes that Someone will Provide the Proper Resolution & Some Helpful Instructions so I can get this Issue Nipped in the Bud ASAP.

Any Useful Knowledge would Be Appreciated (thank you)

First,…I Have a Sansa Fuze 4 GB & I Also Have Both the Rhapsody To Go as well as the Napster To Go Subscription Plans & Both Are Up To Date & Paid For.

I went away for almost 4 weeks & I accidentally left my Sansa behind & upon y Return home yesterday I tried playing it & it said that I Need to Connect to My Computer to Renew My Subscription Tracks & To Sychronize so I Took My Sansa & Plugged in in via the USB Port as I Always Have & I Opened up Rhapsody first & It Would Not Recogize My Sansa as Being Connected & so then I Opened Up Napster & they Didnt Recognize it Either & then Niether did Windows Media Player or My Computer. I then Noticed that the Battery Wasnt Charging Either & the Battery Icon on the Sansa was not flickering with the Green Charger Juice…BUT To Note…Through All My Pididdling Around I Did Notice that the Sansa DOES Start Charging when I Keep it Plugged in & I Reboot the Computer…It Starts Charging…Just Briefly Right Before the Windows XP Boot Page Pops Up & The Sansa did Say “Refreshing Media” but then it stops. The Sansa also says “Writing” & Then “Connected” after it’s Plugged In. I Tested the USB Ports & It Is Not Them Causing the Issue…at least I dont think it is as they All Read all My Flash Drives When I Plug Them In…Well, Except for One, But I think that One Flash Drive May be Damage as the USB Ports Read all the Others & it Also Reads Our Printer…so again, I Dont think its the USB Ports Causing the Issue.

 Now Through My Searching the Forums I Tried Putting the Sansa On Hold & Holding Down the Left Side while I Plugged it in  & that process did make my Computer Pop Up with a Message of “New Hardware Found” & then I Tried to Install the Hardware & it Came Back with A Message that “The Hardware Was Not Installed Because the Wizard Could Not Find the Needed Software”, So then I Went Into the Device Manager & It Does List the Sansa, but there is a Yellow Question Mark Next To it, So then I Went Into It’s Properties & it Reads “The Driver for this Device Is Not Installed (Code 28)” & it gives me a Reinstall Drivers Option, which I hit & it just came back with the same message of not being able to find the needed Software. So then I Tried to Put in the One & Only Disk that Came with My Sansa but its Just the Sansa Rhapsody Software Download…I dont believe it ever came with any Driver Download Software & If it Did, I dont remember ever installing it before. The Only Disk & or Software that I have is the Rhapsody Software, which I have now Uninstalled just incase it was a glitch with the Program & I will be Reinstalling Momentarily & Trying the Hold Down the Left Thingy Again…

…But Im Very Much Hoping Someone can Assist Me with this & Tell me What is Going On & How to Fix it. I Just want to Connect so I can listen to my Already Downloaded & Paid for Songs & I Cant & Dont Understand Why or What is Wrong & I Cant even get the Thing to Charge??..Which I Find Rather Odd?

Now, Im Not Computer Savvy…Not Even a Little, & Just Incase I Just want to metion that we have had some Network issues lately…but Honestly I dont think this has anything to do with this because we are currently connecting to the Internet just fine & everything is working fine, but Just so you are told…This Computer is the Main Desktop Computer & we have a Laptop that Runs Wirelessly off the same connection & My Roomate had Downloaded a Program called FreshUI which it allows you to Tweak the System & Windows Settings & She Believes she may have messed around with Some of the System Sttings such as SSDP Discovery, Peer Networking, HTTP SSL, QoS RSVP, SNMP Service, TCP/IP Net Bio, & Universal Plug & Play & Others Like That & I Will be Calling to Check on all those Settings & to Correct Any that may not be currently Correct, but I mention this because I think that before I Uninstalled Rhapsody that I briefly saw an Odd thing at the top of their Page…in the Tools Section I Believe or in their Preferrences that Read UPnP which I believe is for Universal Plug & Play…so I Dont know if this is something that is reflecting on this issue or if that tool option is always in Rhapsody or not or if it was there due to our computer settings at the time & I will look again after I Reinstall to see if it’s there still but during a reboot I went into the Main System Setting & It Gave an Option to Enable “Universal Plug N Play” & It Said if You’re System is Not Set Up For this Service that the Plugged In Device Wont Power Up At All, & When I Enabled it the Sansa wouldnt Power On AT ALL…Nothing…Nada…So then I rebooted Again & Disabled that again & It Now Powers Up Like it Was & Says “Writing” & “Connected” but Again, It Does Not Charge Nor Does anything Detect It As Being Connected…so I Just Wanted to Mention this Just Incase this May be Effecting it.

But Again, We are Connected to the Internet Just Fine & Everything Else is Working with the Exception of the Sansa & One Flash Drive out of 8 of them.


Hopefully Someone Out there Can Help Me. I Would Be So Very Grateful. It’s Maddening & Im Just About to Go Bonkers!!!:angry:


Do I Need to Install Some Sort Of Sansa Driver & If So, Where Do I Get it  & What Do I Need To Do & Why DiDnt I Have to Do this Before? & Then Why is it Not Charging but does Quickly Charge on a Reboot right Before the Windows Boot Page Pops Up??..I Find that Very Odd?? …No??


Ill Be Waiting Anxiously for a Response & Some Advice.



Hugs Hugs :wink:




“To Err Is Human…But It Feels DIVINE” ~ Mae West


AHHH! wall of text!

Please, break it up a little…paragraphs are much easier to follow:wink:

Okay then!  It’s a lot of information in one block, but your post is most helpful in figuring out just where we stand.

First, hold the power switch up, in the ON position, for 15 seconds.  This will perform a soft reset of the device.

With the device still OFF, slide the power switch down to the HOLD position (orange showing).  While holding the center button depressed, plug the cable into the USB port.  Keep the button depressed while it establishes a connection.  The Fuze should power up, and the battery icon should momentarily go white while the connection is established, then it will begin to roll green, with the wee lightning bolt.  You can release the switch, sorry.

Open a Windows Explorer window by pressing [Windows key] + E, or via My computer.  Do you see the Fuze listed as a flash drive under “devices with removable media”?

Let the device charge for a wee bit.  Double click on the Fuze to open the root directory, and let us know if you see the various folders.  This will verify communications with the device.  These folders will appear empty while in this mode (manual MSC), since you have loaded your data in MTP mode (subscription media wma DRM).

Open the Device Manager via [Windows Key] + [pause / break key] > Hardware tab > Device Manager.  You can have a look at the Universal Serial Bus Controllers part of the tree for a Yellow Triangle of Doom.  If the device is not being recognized properly at this point, right click, select uninstall , and try unplugging / plugging in again: with one caveat.  The communications mode selection.

If the Fuze has charged a wee bit, and it’s happy, manually select MSC mode this time by starting with the power switch back in the center position.  Turn on the device, and go to Settings > System Settings > USB Mode > MSC.  We want to repair the MSC communications mode first, as this is the simplest.

The device should pop up normally when plugged in again.  I prefer to reboot the computer whenever I uninstall a driver, but this is optional- it might work fine on the first reconnection.

Now for MTP, since you’ve learned the ropes with MSC. 

Manually select MTP mode on the device.  Settings > System Settings > USB Mode > MTP, and plug in again.

See if the device cycles on the display between Reading / Writing,  then Connected.

Does the device show up in Windows Explorer, at the bottom of the list now, under other , as a media device?

The MTP drivers are integrated into Windows Media Player 10 and later.  If you don’t have WiMP11, it’s a great upgrade for MTP.

Go to the Device Manager.  You’ll see the Sansa listed under Portable Device, or at the bottom of the tree.  Right click again, select uninstall , unplug, reboot, and plug in again.

Hopefully, your MTP connection will be restored.

Next task, open the Rhapsody 4 client and resynchronize, then Napster.

Let me know how it goes!

Bob  :smileyvery-happy:

Hi Bob:  I am a newbie on this site, so I am using the only post that appears to have some potential relevance to my challenge.

As a new Sansa Fuze 2 GB owner (purchased from Best Buy, St Petersburg, FL, I have been able to successfully start-up the device, and use its simplest features, in conjunction with my HP laptop under Vista x64.  However, in installing a newly purchased Micro SD card, I am not able to see it on the Windows Explorer view of the Sansa file folders display. The card does show under the System Settings “Info” feature display.  Hopefully, I have missed only a simple step in the correct process to insert and obtain recognition of the Micro SD card on the Window Explorer mode on my Laptop.  Obviously, this is where I can transfer some data (photos mainly) from my laptop onto the Micro SD card.

I have also not had success in dealing with Best Buy’s Rhapsody free 30 day trial service.  I canot discover how to take advantage of the free downloads for the duration of the trial period.

Any help/advice with regard to either, or both, of these challenges would be greatly appreciated.

Thanks, in advance.  Arbyem

Hi again Bob:  Oops!  “Haste makes waste!”  Having disconnected the Sansa Fuze from my Usb port on the laptop, and reconnected it, I now see the Micro SSD card as an external device to the Sansa MP3.

However, please help in whatever way possible with my other challenge with the Best Buy Rhapsody service.

Appreciatively, Arbyem

The Rhapsody-To-Go service isn’t about free downloads, it’s about unlimited access.  As long as you subscribe, you can download 'till the cows come home.  Think of it like cable or satellite TV…for your Sansa.  You can access the latest and greatest from a huge library.

To use your Sansa with Rhapsody, you need MTP mode active for the secure WMA transfers.  On the device, Settings > System Settings > USB Mode > Auto Detect, or better yet,  MTP.  You must have Windows Media Player 10 or 11 installed on your PC for the MTP drivers.

Once you plug in, open the Rhapsody 4 client, and the Fuze must show up as Sansa Fuze (n)GB, in Caps and Smalls, meaning it’s in MTP mode.

If the Sansa displays as E: SANSA FUZE all in capital letters, the device is in MSC mode, and To-Go transfers aren’t possible,

Right Click on the device and select Authorize.  That’s all there is to it!  Then drag and drop from the Music Guide until your mouse hand gets tired.  Well, you don’t want to overdo it.  The bar at the bottom of the screen will show you how much space is available.

Bob  :wink:

Message Edited by neutron_bob on 03-18-2009 04:03 PM

Hey, LadyCore, did you get your fuze to work right?  Just curious.