Help! I Deleted USB Mass Storage Device. How do I get that back?

Because I had difficulties using Rhapsody to put music onto my Fuze, I followed the advice of one of the members here (you can look in my user record), and downloaded and installed winamp.

However, upon launching, winamp seems to have noticed my Fuze (it even had the playlists) and my Fuze was connected to the computer, but then an error message popped up, and winamp was forced to close.

I started winamp again (with the Fuze still plugged in), and winamp did not notice the Fuze.  I then disconnected the Fuze and reconnected it.  In winamp, for a while it said something about loading fuze, but then ended with no portable device listed.

So then I looked here on this forum for answers and got here: Winamp &… .  I followed comment 2’s instructions.  There was no “Yes, this time only” part.

Installing the driver for the USB Mass Storage Device did not work.  The troubleshooting suggested uninstalling and reinstalling the device.  I’m confused about this.

Anyway, I did the same thing (with the computer manager) but chose MTP device.  This ‘worked’, in that it was able to install.  However, the Fuze still didn’t show up in winamp (or media monkey, which I installed later).

So I went to installed USB Mass Storage Device again, only now it is not there as an option, only MTP is.

Do I have to put in the CD that came with the Fuze and reinstall Rhapsody (which is only what the CD seems to do)?  Will that make USB Mass Storage Device return?

Message Edited by jumpydwarf on 03-05-2009 10:22 PM

Message Edited by jumpydwarf on 03-06-2009 01:10 AM

In Windows Explorer, using MTP mode, there may be a delay as Windows searches the device.

Give Windows a few moments to complete the search.  With 10GB loaded on the Fuze or e200v2, as a quick test, the delay is similar.  Check the display of your Sansa.  You will see that the device is communicating with Writing / Reading displayed.

For fun, I have tried opening the Music and Album folders.  This can take considerably longer as the thumbnail images are loaded.

If your Sansa is not being recognized properly, manually select your desired mode, on the device, by going to Settings > System Settings > USB Mode > [MSC or MTP].  Auto Detect can be selected after troubleshooting is completed.

Check your device using the Device Manager.  Select the Sansa, and uninstall the device.

Unplug, then plug back in after the database refresh (if this appears on the device).  Windows should find the Sansa and reinstall the driver.

If you are using MTP mode, update to Windows Media Player 11 for the latest MTP drivers.