Getting Music from WMP to my e260

While trying to transfer music from WMP to my e260 it transfered a couple of songs and then had a error symbol that said that MWP had a problem  moving those songs.  Suggestions?

Forget WMP and just transfer the files in Windows Explorer using MSC mode.

Well that worked at first but then it started giving me a “Cannot copy ________ (the name of that artist) The device has either stopped responding or has been disconected” 

Since I had not disconected it,  I am assuming that it stopped responding I then unplugged it, plugged it back in and then tried again it still would not copy those artists.

Were you in MSC mode?

Have you tried formatting it?

Have you tried a different cord?

No I was not in MSC mode because when I tried to put music on it  there was no folder for music. I tried creating a new folder but I could not play the music on the device.

 I just had  this problem http://forums.sandisk.com/t5/User-guides-Firmware-Software/Firmware-problems/m-p/228362#M4014 . last night I tried formating it from WMP even though I was told not to, It "almost bricked "  however I followed the steps again to unbrick it.  That worked so I tried putting music on it again, and I got the problem that I said at the start of  this topic. 

What do you mean by trying a different chord?

So… ?

Any ideas?