fuze+ stuck on "loading"


I just got a 8gb  fuze+, updated firmware with latest, loaded 6 gb of mp3, vbr between 256 and 312 kb, and the thing is stuck on “loading”.

I tried to turn it of and on, but it does the same thing, sticks on “loading”.

I was thinking to reformat it, or reset the firmware on it, but when I connect it to my computer, it is not detected (probably because it’s stuck on “loading”)


Are you sure it’s stuck, and not just building its database? 6GB of files are going to take a few minutes to refresh. Although, if it takes longer than 10 minutes, something’s amiss. Maybe it’s having troubles reading the ID3 tags of some of the files. That can cause a freeze-up or slow down of the database refresh.

It’s been like that the whole night…how do I reset the device? Every time I turn it off and on, it shows the “sansa” screen and then goes into “loading”…

Whoa! That’s way too long; something’s not right here. :dizzy_face:

You can perfrom a reset by pressing and holding the power button for 20-30 seconds. I would then format the player to start over. I’d also recommend checking your ID3 tags on the files as bloated tags or the wrong format can cause slow downs or freeze-ups of the database refresh.

With 6GB of files, this may seem a daunting task, but MP3Tag (freeware) can make quick work of it. Set the default Write format to ID3v2.3 ISO-8859-1 in the Tools menu. Also clear out anything in the Comments field of the tags.

Then when re-loading, consider loading a few folders at a time. If it starts doing it again after a particular addition, this will help you narrow down what files may be causing the problem.

thank you so much!

Personally, I really hope that the next Sansa player that Sandisk releases is better able to handle tags. This is deffinatly enought to confuse people. I’m sure that for every person who comes to these forums with this problem, there are ten more, who have just given up, and returned the’re players for a refund.:cry:

i seriously dont know what to do, I have 11GB of files all on a microsd (sandisk), when I start the fuze with it, it says loading card…after 2 minutes it reboots and this becomes an endless loop. I tried to delete comments tag and to apply that chartset, it still happens :S

Is this even a player?:S unbelievable

How do you know that it’s stuck and not still loading? 

Why not try with a more reasonable collection, such as 75 songs on the internal memory and 150 on the external.  I think that you’ll be pleasantly surprised with the screaming fast responsiveness of the Fuze+ at more reasonable capacitites.  It will make you forget all about flashing through 10,000 songs in a split second on that 80 gig iPod.