Fuze has no power, but when connected to computer

Ok, so like most of what i’ve read on here this Fuze just turns off. i’ve had it for around 2 years now, and it has worked perfectly fine with no glitches at all. Suddenly, it turns off while im listening to it in class, thought it was just power save, so i try to turn it back on and nothing happens, so i tried to charge it, but this was ineffective, the MP3 player gets this white screen on it when i plug it into the computer via. USB cord, and while it is connected i am able to turn it off and on, but i get nothing more than this white screen, which it is on while i am typing this, so any help to how i can get this back up and working, also i have not put on any recent music for a while so it isn’t a corrupt file that would do this, and i tried putting the update 2.023 and it had no effect, im not even sure if the Fuze was updated. so can anyone help me out? and yes i’ve tried the 15 second hold, the 30 second hold, holding those both while it is plugged into the computer. and holding other buttons in while holding the power button, any other suggestions?