Fuze freezes with 4GB SDHC Card

I got a 2GB Fuze, latest firmware (V02.02.26A) and I have a problem getting it to work with 4GB A-DATA Class 6 SDHC (http://www.adatausa.com/product_show.php?ProductNo=AMC2CL6BK).  I’m using Windows 7 if it matters. If I turn the player on with the card in the slot it freezes on the clover leaf logo.  If I put the card in when the player is on it freezes immediately.

On the other hand, a 2GB SD card from the same manufacturer (http://www.adatausa.com/product_show.php?ProductNo=AMCSZZZBK) functions perfectly.  I’ve tried reformatting the 4GB card (FAT32) with no luck.  It works in other devices (digital SLR, card reader, etc.).  Any ideas? 

 Do you get the troubles with the card when the player is MTP mode? Does it also happen when the player is in MSC mode?

Are you using MTP for the USB mode? Perhaps you might have less troubles using the player with a card in MSC mode. Reformat the card in your card reader using  Format  [driveletter]:  /FS:FAT32  /A:32K  

It is best to only insert or remove a card while the player is off.

Tried all you’ve suggested.  Still no luck. :cry:

It could be faulty card.  I’ve read where ebay had some fake cards and wouldn’t work.  Maybe try another 4gb card if you can.  I know with video people were having trouble with Kingston cards (me included).  I have a bunch of SanDisk cards and they work fine.  I have a 2gb other brand (can’t remember the name at the moment) and it works too.

Do you have a card reader to plug it into the computer and check it out?  Maybe format it that way?

Another device you can put it in (if you dare) and see if it works in there?  And plug that into the computer?  For example, my cell phone takes these cards and I have a data cable and can view the card on the computer (somewhat, not as good as the Fuze).

The card functions perfectly fine in the reader and in my Blackberry 8830.  Only Fuze has a problem reading.  :(

Then it’s the card, I believe.  I think sandisk isn’t compatable with some cards (like Kensington 4gb for video–the music worked fine on it, but not video).  If you can get sandisk cards in the future.  That’s all I get now.  They work perfectly. 

I’m using a Kingston 4GB microSDHC card with no difficulties although I do not use the video function at all only MP3 music audio and some photos.

Seems I read somewhere on the forums that it is best to format the external card and then only use it for the Fuze, i.e., no other gadgets after that, something about slightly different file characteristics or some such…

Message Edited by Bucko on 08-12-2009 11:52 AM

Well, I re-formatted it completely like was suggested above, and Fuze freezes on boot up before anything even happens. :frowning:  There’s also one other issue about video play I’ll start another thread if I don’t find the answer too through search.