1Gb sd card freezes

First, Hi to everyone as that’s my first post. Glad to see a strong community here.

I’ve just bought a fuze 4Gb with firmware 1.1.11.

I’ve had an old micro sd card of 1Gb, which does function OK in all my other device.

but not so my my sansa fuze. Let’s go to the simpliest situation I could have where the problem arises.

I’ve formatted my sd card with FAT32 : (yes I’m on linux and considered linux support before buying)

$ sudo mkfs.vfat -F 32 /dev/sdk1

It’s formatted OK. I checked it :

$ sudo fsck /dev/sdk1
fsck 1.41.3 (12-Oct-2008)
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
/dev/sdk1: 0 files, 1/248184 clusters

To be more precise, I do this while the fuze is in MSC mode (no MTP for me please) and the card inserted. But in order to avoid the freeze, I have to:

  1. turn the fuze off

  2. insert the sd card(it is really well inserted, with a click noise)

  3. plug the fuze to the computer

  4. turn the fuze on

Linux then automatically mount both the sd card and the internal memory. Before formatting, I unmount the sd card of course.

Now that the card is freshly formatted, I unmount the sd card and the internal memory then switch off the fuze and finally physically pull its plug off the computer.

Then I sitch the fuze on again. First, the internal memory is quickly updated. And then a second “refreshing your media” begins, but it is frozen nearly immediatly.

No reset is able to get beyond that.

Could it be a problem of THIS micro sd card of mine (I have no other to test yet) or what?

The internat memory does not have any problem.

I then try  firmware 1.1.22 as well. That’s frozen as well (but just after the blue ring of let is light on – there is no refreshing message). Also, I can not access to the fuze at all with the sd card inserted if I apply the protocol above.

In order to get back a functional fuze I need to pull off the card, and reset the fuze a first timeso that the refreshing process begins but gets frozen, reset a second time and then the refresh completes and everything is back to normal.

I keep firmware 1.1.22 (to get flac support) from now on.

Message Edited by oggie on 01-27-2009 11:33 PM

You may try some trouble shooting if possible.  

Try another microSDHC card to see if another card works through your process.  

Or

Take the formatted card and try it on a Windows PC using an adapter to plug it in. (USB adapter or SD adapter).   

 also you could try formatting it on the PC with FAT32 and then try it in the Fuze.

Thats all I can suggest,   Good luck :slight_smile:

thanks.

I forgot to mention that the very fist time I inserted the SD card which had only picture at the time, it worked OK. I could see my pictures on the fuze.

Troubles begun when I tried putting songs onto it.

I won’t be able to fetch another micro sd card before a week.

formatting as fat 32 via linux or windows does not make any difference. besides, I have noted that this microsd-card is not write-accessible when mounted onits sd adaptator no matter how I put the write protection switch. This might hint it is defectuous. I don’t know for sure, for I have not got any other micro-sd. ot that ight be the adaptator that is poor.