Freezing progress bar while ``Refreshing your media''

I’ve noticed a number of people posting on this forum with problems regarding the Clip+ (and other models). Specifically these problems have been a frozen progress bar while the device is ``Refreshing your media’’. Some of the issues reported appear to be linked to the use of SD cards, however others seem to be just problems adding new files to the music folder and then letting the device update.

I had similar problems with mine—having added a folder of music (mixture of mp3 and ogg files), I got the freezing problem occuring. It was only when I removed a few jpg files (album covers) and a load of .DS_Store and ._.<the file> plus other cruft Mac OS X leaves on the disk that the device refreshed correctly. I have yet to determine whether the removal of the jpg files was what accomplished this or whether the dot files were also causing problems.

Unlike some of the posts in response on this forum, it was nothing to do with ID3 tags.

Clearly, then, there is an issue with the software that reads the files on the disk being far too fragile and I’d imagine that it would be good if SanDisk would fix this issue. 

I can kind of understand the device having trouble if there was a corrupted mp3 file (even then it should handle the problem gracefully), but what I cannot understand is why the software attempts to read files that are not music files (e.g., jpg or the dot files). The code that reads the files on the disk should be far more robust and shouldn’t cause such catastrophic failure. 

Thanks for the post.  It’s the dot files that the Mac creates when a file is transferred, that chokes the Clip (as well as other audio players and devices, such as cameras).  Transfer software for the Mac such as Kopymac will avoid this (available at CNET’s download.com). 

Thanks.

Why does the software have problems with dot files? Why doesn’t it just ignore them? 

Others have asked as well (making the Clips more Mac-friendly).  For whatever the reason, SanDisk didn’t build that into the Clips (and really should have . . .  get the Apple users as well!).  Apparently, this is not at all uncommon, with other audio players and with cameras.

I guess one also could ask, why doesn’t Uncle Steve build it into his OS’s not to cause the issue to begin with?  If one wants to be cynical, one might think that it’s a marketing thing, to try to stop Mac OS users from leaving that universe . . . .

im having this problem too, though only alittle bit different., its the sansa clip+ 4gb, but it gets to the refreshing media screen, and then resets and does it all again, its fine when its connected to the computer, but as soon as yo disconnect it, it starts doing the same things again. i have tried resetting it, formatting it, and holding each of its buttons as its turning on, but none of that works, any ideas? help would be VERY much appreciated.

As the player is OK when connected to your computer, can you reformat the Clip via your computer?  That could give you a clean, fresh start.  Note:  this will erase the content on your Clip–transfer any files you want to keep to your computer first. 

ah, thanks for the quick reply. i have tried formatting it, but after doing that it still does the same thing, any other ideas?

Manually re-apply the firmware.

The firmware posts (with download links and instructions) are “stickied” (shaded grey) at the top of the page.

@xearez wrote:

ah, thanks for the quick reply. i have tried formatting it, but after doing that it still does the same thing, any other ideas?

And you tried a reformat via your PC, right? 

You also may want to run an error correction (the goold old CHKDSK) on your Clip:  right click on the drive when connected to your computer, go to Properties, and there should be a tab that gets you to the error correction option–be sure to tick the box to correct errors that are found.

Hopefully this, or the above, will help!

Thanks to lazy, incompetent engineers, I have wasted hours loading my new piece of crap sanzsa clip zip only to find it is inoperable. “REFRESHING YOUR MEDIA MY ASS!”. I was replacing an older unit that wouldn’t accept acc etc, so I was thiking "Newer, better, etc. Guess again! As a consumer I am so sick of sloppy engineering I can’t begin to express it it effectively. I will either get company assistance to correct the problem or will buy a bunch of them, only to return them for refunds, thereby sending a backlog of these **bleep** units back where they belong.

I have a MAC, followed the instructions. I also had to go to each album & delete the mp3 files ( that were created for the older sansa clip. so that I wouldn’t load dups). So even though loading a Sansa takes much more time than an ipod, it was magnified this time, just like last time, only in reverse. last time I had to create mp3, this time I had to delete them.

Bottom line, Sansa either needs to get it together once and for all, or we ALL need to bite the bullet & buy an ipod.

Sansa—what a pathetic joke you are!!!

I get the feeling that you’re frustrated . . . .

Perhaps if you would actually explain what the problem you’re having is, people could help.  Venting can feel good, but doesn’t necessarily fix the problem.  

Unfortunatelly, there can be Mac or aac issues with the Clips.  Part  of this is Mac-caused, with Apple refusing to play well with non-Apple devices.  Do I sense a plot there?   :wink:

If there was a delay in the refreshing of your Clip (is that the issue you’re having?), did you leave the player alone to refresh, a good, long time?  Depending on the size, this can take 20 minutes or more.

I have this “stuck on refreshing your media” problem, too. It’s a Clipz and I’m using n a PC.

I have read lots of forums where this problem is happening. I have

  • edited the tags to be ID3v2.3 (ID3v1 ID3vd.1) using Mp3tag
  • reinstalled the firmware twice

If I add albums v e r y    s   l   o   w   l   y, like one album at a time, I can sometimes get it to accept a new album. This is the process:

  1. Plug into the computer.
  2. Get Exception Error with a hex address. Cancel, Retry, Continue?  Click continue 4 or 5 times and eventually an Explorer window comes up. Music plays ok from the device while it’s connected to the PC.
  3. Add ONE album
  4. Eject & unplug it from the computer
  5. It will say Refreshing your media for a little while, then reboot itself and display the flower screen again
  6. Sometimes it goes entirely blank and I have to hold the on button for 15 seconds or longer to get it to switch on
  7. If it gets past the Refreshing your media, then I try another album
  8. If it gets stuck again, I start over.
  9. I’m now at the point where I’ve just deleted an album that caused it to fail, and it’s STILL stuck on refreshing
  10. Hold down the off button for 15 seconds (or more) to make it switch off.

This is painfully slow and tedious. I have wasted many, many, many hours over the last 2 months faffing around with this and, frankly, I’m quite annoyed. I bought it in the US when visiting so I can’t return or exchange it. I bought it because it got good reviews and sandisk removable media seems generally reliable. Who was to know that I needed to search for this particular problem, which is clearly VERY COMMON.  So I have full sympathy for the person who was “venting” earlier.

I don’t know what else to try and I’m very tempted to throw it into the fireplace and have the satisfaction of watching the sodding little piece of crap melt.

Since the vast majority of people reading the post are most likely happy with the device, your comments are somewhat insulting. It’s like you’re saying you’ve evaluated the device, decided it’s worthless and the rest of us are just a bunch of losers for not realizing what gullible people we all are.

A number of contributors to this forum are very helpful. It appears your problem is some issue with using the device with a MAC. 

So stay with the MAC and get an ipod, you might want to let us know if that proves to be less than perfect.

I’m sorry you feel insulted and I’m delighted for you that yours works. I’m still angry that mine doesn’t and that it has caused me to waste many hours.

As I said in the first line I’m USING A PC.  It has nothing to do with it being on a Mac unless ‘on a Mac’ includes  the fact that my music collection was once held in iTunes before I switched it to Nokia Ovi.

I’m willing to conclude the problem IS with the tags, even though I’ve attempted to edit them. Or the device is faulty.

Regardless, it doesn’t stop me being angry that I’ve had to spend so much time trying to troubleshoot what should have been a straight-forward and easy-to-use new device.  My Nokia phone actually plays music pretty well, it just has a limited capactiy. It certainly doesn’t keel over because it doesn’t like the tags (I never paid any attention to tags until I got this stupid little player).

I only wanted the mp3 player because (silly me) I thought a dedicated mp3 player would do the job better.

I found this thread after having the problem where the player freezes on the Refreshing Media screen and I did find a solution that worked for me.

I first tried a couple of times to reinstall the firmware but still ended up back with the same freezing problem.  Also, I am not sure what caused the freezing in the first place.  All I know is that it happened on the same day that I gave it to my daughter who was using a Linux machine to add some of her music after I had previously set up the device with RockBox (in Windows)  and some of my music to test it.  Of course she wanted to delete all of the music I had put on it and added her own.  I do not know if she might have deleted something to cause the freeze issue or whether it had to do with using a different OS to add her music.

What I did that worked was to reformat the internal memory in Windows and then copy over the firmware .bin file to basically start over from scratch.  I did this with the SD card removed.  I had told her to put all of her music on the 8GB SD card so I left this intact and the player was able to find and refresh this music without a problem after I did the reformatting and firmware update.

The only thing that was a little tricky was that the device would not always be recognized by Windows when I plugged it into the USB port (Windows just wouldn’t do anything).  I tried some combination of resetting the device (push and hold power button while pressing the menu key up to 20 seconds) and forcing MSC mode (push and hold power button while pressing center key)  and shutting the device off before plugging it in to get Windows to recognize it.  Once recognized, it is just a matter of clicking on the device from my computer and selecting the internal memory with a right click and select Format.  I was not given any options for the type of format so I assume it was FAT32 for the 4GB device.  Once formatted, just copy the firmware over to the internal memory and it should reinstall.  This was on a PC so I can’t be sure if this would work for the MAC users as well.

Hope this helps those of you having this problem since SanDisk doesn’t seem to have a solution posted in this thread.