The following info may or may not help someone else with similar issues to myself.

I came to this thread looking for an answer to why I could not access my 64GB microSD card (replacement from SANDISK) on any of my android devices despite reformatting to FAT32 (using HP USB Disk). Card originally was exFAT.

I used the suggested formatting tool SD Association’s Formatter from this thread and also selected the Format Size Adjustment option as ON with a quick format.

My card was then recoqnised in my Android devices (Toshiba AT300 & Samsung Galaxy SII).

The tool had set the file system back to exFAT.

Here is a snippet from the tools manual:

_ Format Size Adjustment _
If the formatted capacity of the card is not a multiple of capacity in a cylinder, some hosts may not
access the card successfully. This option adjusts formatted capacity to a multiple of capacity in a

This option does not adjust the formatted capacity. Usually, this option should be selected.

This option adjusts the formatted capacity to a multiple of capacity in a cylinder. This option may
reduce the formatted capacity.
This option should be used by specific users who encountered a trouble with formatted capacity.

After searching all over the net and many failed attempts to format my 64GBsdXC it brought me to this thread. I have had this card in a netbook for 6 months but then I decided to use it as my media storage for my GALAXY S5. In the last week every time I tried to copy/add or erase delete any pictures or music card would look like it was done but files would return. Today I took it out and decided to manually move the media and that’s when I noticed that files just reappear after. So I decided to Format the card with it inserted into the SD card adapter to no avail.  And now here I have a card that is practically year old and now a dead weight. I guess I’ll just avoid purchasing SanDisk after all these years as a loyal customer. Such a disappointment. 

@thingamajig wrote:

And now here I have a card that is practically year old and now a dead weight. I guess I’ll just avoid purchasing SanDisk after all these years as a loyal customer. Such a disappointment. 

Or you could simply call SanDisk and have it replaced under warranty. :confounded:

It seems the ultra series of cards have a very high failure rate. When they fail, they go into read only mode so that the existing data can be retrieved when it fails. I would not suggest storing sensitive data on these cards.
Fortunately they come with a lifetime warranty from San disk. I just rma’d a 64GB ultra and they sent me an Extreme series. Hopefully more reliable.

One thing that irks me about this industry is that they get away with false advertising so openly. The 64GB card only has 59GB capacity. Without explanation I might be inclined to say it is a reserve for bits that go bad in the future but no. They have arbitrarily redefined 1GB to 10^9 instead of 2^30. I hope they next time the ceo of SanDisk goes to the grocery store and buys a dozen eggs the container will only have ten and the one pound steak will only be 10oz because the supermarket redefined what a dozen and a pound is.

@haveblue wrote:

One thing that irks me about this industry is that they get away with false advertising so openly. The 64GB card only has 59GB capacity. Without explanation I might be inclined to say it is a reserve for bits that go bad in the future

Here’s the explanation:

And it’s NOT false advertising. And it’s NOT just SanDisk.

I tried the various methods to format my 64GB Micro SD card described here, but none worked on Windows XP, Vista, or Win7computers. Not using USB or SD card slots. Not using SD Formatter. I tried all combinations of FAT32, NTFS and exFAT. They all only detected a physical size under 32GB.  Typically 26.5GB

I then entered the 64GB Micro SD card into my digital Panasonic Lumix camera and it detected 58.5GB and formatted it using exFAT file system in seconds! 

I too have the same problem with Sandisk SDXC 64GB memory card like the post by MORTALLKOMBAT.

I’m sick with it now. It manifests strange problems…I take pictures and few minutes to few days later, the new pictures I took is gone. Or the pictures I took 99% of the images are grayed out. I got so angry, I formatted it using the phone formatter.

Happy thinking some inconsitencies cause the proboblems are gone after formatting…NOOOOOOOO!!! Pictures are gone again. I am in the last leg of my vacation. I took bunch of pictures and they are GONE!!! Only old pictures dates back 1/20/2015 are hanging around. Get this!!! AFTER FORMATTING, NEW PICTURES ARE GONE AND OLD PICTURES COME BACK!!! HOW IS THAT PISSIBLE!!!

I’ve been fighting this problem since 1/20/2015. Now 3/25/2015. I lost the pictures over 2 months worth. Vacation pictures/videos gone!!!

I also formatted the card using Win7 with USB connected. After restarting the phone, new pics gone and old pics come back.

The card is around 1/2 full. WTF SANDISK!!! Even if Sandisk replaces with new one, I’m afraid to have the same problem!!! You know???

I came here with the same problem. I bought two 64Gb Sandisk MicroSDXC cards with adapters. Firstly, the fit of the adapters is horrible, which is probably a big reason for the failure rate. I don’t have any devices that use the microchip directly, so I had no choice. It shouldn’t matter.

Neither of my Nikon cameras, a D5100 and a Coolpix S32 could read or format the card. My Mac Pro desktop could see the chip, but couldn’t format or write to it. It reported read only mode. I even tried an external 3rd part SDXC reader to see if that would make a difference. Nope.

I took the cards to work and tried on my 64bit Win7 machine. Nope, same thing. Tried on my iMac and got same problem.

Came here, and downloaded the SDFormatter - same problem - chips are read only. Couldn’t do a thing with them. I almost gave up. But then I remembered that my Macbook Pro laptop (from 2011) had an SD card reader built in. Can’t recall ever using it. Popped a card in a voila - it read the card and allowed me to format using the Apple Disk Utility.

After that, both cards now can be read and written to by both cameras. But, neither camera can format the cards.

It’s really weird. I don’t know that I can trust them.

I’ve had the Sandisk Ultra 64GB Micro SDXC for over 3 years now. Bought it for my Note 2 and it worked great for the first year then the card got corrupted and I had to RMA it 2 years ago. That worked for a little under 2 years then it corrupted again with unable to format and I RMAd it again. This time however my luck seems to have run out.

When my 2nd RMA card arrived I popped it in my Kingston SD card reader and after transferring some files it just froze and couldn’t be ejected and eventually I just unplugged it and tried again. Same issue it kept freezing while transferring files so I tried to format the card and was given the error that Windows was unable to format. I tried plugging it into my Macbook and it couldn’t format on that either so I asked for an RMA again.

Now with my 3rd RMA card, SAME ISSUE but this time I bought a brand new SD card reader (Transcend SD Card Reader) and still the same issue almost immediately. It froze when transferring files and card is unable to be formatted. I ried other SD cards to see if it was a reader issue but those SD cards (Sandisk, PNY, Generic) seem fine but they were smaller capacity and none SDXC and all those read fine on my phone and readers. I was able to format each of those successfully as well so the issue definitely seems to be with the SDXC.

So today I contacted Sandisk for my 4th RMA and I was promised an upgrade to the Ultra Plus line but honestly at this point I don’t even think that’ll work. I’ve tried using various different phones, readers and computers and they all seem to have the same issue with this card. I’m really not sure what to do if my 4th RMA fails again.

I tried various formatting programs as well including SDFormatter V4.0 and absolutely no luck with anything. I’m not sure if this is a Sandisk issue or just a general SDXC issue but what I do know is that I am slowly losing faith in their products. However on the bright side each and everytime I have contacted their support, they have been of utmost help. I’ve had a very pleasant experience each time however I wish their products would reflect their customer service.

I’ve been there. there is no problem with the operating system you are using. it is because the SD card gets problem. 

there are quite a few solutions I found online and I believe there must be at least one that can fix the problem, such as format it at Disk Management, using command line or check and repair bad sectors.

For me I prefer buying a new SD card, as SD card can’t be completely repaired. (One of my friends whose work is repairing computer told me).

Same problem done with my card also i have 64Gb microSDXC UHS-I, Whne i removed the card when i submitted to my my HTC Desire 820 phone to at Gallery, after service of i put the memeory cards and its showing no data and also not detectin the card. I also connected to my  laptop its showing that formate the card to use. please help i want an replace ment i just but the card in march 2015. 

The article windows was unable to complete the format may help you!

I had a Sandisk micro SD to SD adapter that would move the slider to the locked position as it was inserted into the card reader. The same Sandisk card used in an old adapter I had of a different brand worked just fine.

If you have a GoPro, you can use it to reformat the card. (settings>erase>erase all/format)  This worked for me after failed attempts to reformat using diskpart.exe and other reformatting tools. 

I had 64GB SanDisk Extreme Card that was working fine until I had my son first Birthday. my heart is broken I lost all of it hundreds of photos and videos with a DSLR camera. this is crazy SanDisk where is your QA?!?!!

My card is asking me to format everytime I insert it in many machines including Mac. it used to show 64GB now only 30.6MB please help me to recover my son photos I tried everything possible :frowning:

Same here so what I did I broke it into pieces because it’s useless! Lesson learned not to buy Sandusky products next time!

It appears that I am having the same problem with my new sandisk 64 gb card as many other people are having.  I guess I’ll just have to return it to Amazon and try a different brand.

If you purchased a card on eBay they’re more than likely counterfeit and that’s probably what’s going on!

I was able to format my card eventually…

I had searched and tried many ways including formatting via command prompt, formatting through my android and formatting through windows.

When trying to format with windows it would only give me the option to format it at 27gig.

In my android device it said that it successfully formatted and appeared to 64gig. however when connecting to USB in window it was still only 27gig. 

I finally got it to format using the DJI OSMO UHD camera whilst connected to a USB port with Windows 7. upon connecting to windows through the camera, windows prompted me to format it and it allowed the full 64gig to be formatted… That’s it!

I hope it helps someone out as I was almost going to try and get sandisk to replace it.

Good luck!

I’m sadly also a victim of the formatting.

My problem is how to _un_format my SD card. Yesterday, I was messing with my camera, and one of the options was to format. I did it, but my 64gb micro-sd somehow formatted to 30gb. All of my files were wiped off or at least hidden, and I need help of how to unformat my micro-sd card.