FM Radio Frequency - WTH

I bought a Fuze.  I’m quite happy with it except for one thing.  The Radio.

The radio frequency goes in 0.2 increments to odd number channels only!  For instance, 95.1, 95.3, 95.5, 95.7, 95.9.  That might be fine for the US of A but it’s not fine for other countries like the UK.  For instance, Capital FM uses 95.8 and many others that use “even” number channels.  I would really appreciate it if your next firmware would allow access to these radio bands. It really sucks having something crippled on such a great player.

(eg. http://www.londonradiostations.co.uk/)

I’ve never had this issue with my previous iRiver players, which weren’t even half the player than the sansa is. 

Let me know when or if there will be a resolution.  Thanks.

EDIT:  It’s a Sansa Fuze 8GB model purchased in Canada.  I travel to UK alot tho.

Message Edited by neogeo on 11-07-2008 05:22 PM

Message Edited by neogeo on 11-07-2008 05:28 PM

2 seconds of searching found this:

“Go to Settings > FM Settings > World, and you should get the even increments.”

Go into Settings -> Radio Options -> FM Region and change the setting to “World”

That should get you where you need to be.

What i find a little strange: when it is on ‘world’, pressing the middle button seeks the next station.

When it is on ‘USA’ it doesn’t work? Is there a difference between our european fm radio and american?

But now i know why my Kensington fm transmitter only does 0.2 increments.

Right.  Now I get 0.05 increments and need to hold longer.  As long as it works I guess.  It wouldn’t hurt to have a 0.1 in there.  Like Goldilocks,

This porridge is too hot!

This porridge is too cold!

This porridge is just right!

Thanks for the help.

Are you using the European firmware notated with the ‘f’ suffix? Check you firmware version (SETTINGS > SYSTEM SETTINGS > INFO). If the top line ends with an ‘A’ you have the American firmware version and this could be your problem. You can change the firmware here. The European version has an ‘F’ at the end denoting FM. There is also an ‘E’ version (European without FM) :smiley: