Firmware Updater troubles :(

I just downloaded the Sansa Firmware Updater, and when I go to run it, an error message comes up telling me “The Installation failed. Please try again later.” I started it up again, and got the same error message. I then waited about 30 min., and sure enough, same error message. What am I doing wrong!?

OK The fact of the matter is that 90% of us who have been on here very long will tell you to just ignore the updater. On the fuze go to Settings> System Settings> Info and look at the Firmware number If it starts V01 Go to the Thread called Fuze Firmware Updater, and in the first post find the firmware update that starts V01, and then follow the instructions on that post. If your Firmware Number starts V02 find that firmware and follow the instructions.

Hard to say, but a lot of us don’t use it at all. It’s quick and easy to add the firmware manually, and doesn’t add any software programs  to your computer The first post here

 has the whole story. 


I did not find anything explaining that the Updater don’t work.

I understand it’s better to act without it, but, why is there an updater ?

The new one did not find my Fuze and when once a month it finds my Fuze, it did not update anything.

I understand it’s better to avoid the Updater…

What does Sandisk staff think about that ?

Thank for the help.

At least, I understand I am not only silly.

Rarely do Sansa staff come here.

Fuze updates are rarely even once a month. You can see if there are any by just checking the front forum page every month or two. 

The Updater is there to make things simple for people who are afraid to update by themselves–unzipping a file, dragging it over–but you’re better off just doing it manually The Updater slows down your computer on every reboot and phones home whenever you connect, all for updates that hardly ever happen.