FAT32 and skipping issue solved

I purchased a blue 1 gig and a 2 gig SD for my 10 year-old.  I tried to load 850 meg of MP3s (165 files) into the the root directory of the 1 gig SD that came with the unit.  It stopped accepting files at aprox. 800 meg.  Tried the same process with the 2 gig SD and it also stopped accepting files at aprox. 800 meg. 

So I gave up and I gave the unit to the kid for Christmas and the unit worked fine with just 800 meg of the 2 gig SD used.  However, the remaining empty 1.2 gig of the 2 gig SD was bugging me.  So today I put on my thinking cap.

I thought that it might be a FAT16 issue, so I formated the 2 gig SD to FAT32.  I was then able to load 1.8 gig of MP3s (393 files) to the root directory at this point. (I can fill it to 2 gig if I choose)

However, after the format to FAT32 of the 2 gig SD and the loading of 1.8 gig of MP3s (393 files) onto it, I turned the unit on and it played the first song played at half speed (which I thought was an improvement, but my kid was not ammused). So I twisted the botom and the next MP3 played fine until it was shut off again and then powered up again.  It again played the MP3 at half speed and again I’m amused.

“OK”, I thought to myself, “I can live with this.”  I gave it back to the kid, and then within 20 minuets the unit started skipping. What it did was to play a portion of a MP3 and then without notice or reason, skip to the next MP3.  It wqould do this over and over again.  At this point my kids unhappy, but I’m still amused, I digress.

So Dad to the rescue, I dropped a dime on SanDisk tech support and they told me to add directories.  I added some directories to the FAT32 formatted 2 gig SD, moved some MP3s around and both of the symptoms remained the same

Long story short (although it might be too late for that), I reformatted back to FAT16 and added 1 directory named “music” and was able to load 1.8 gig of MP3s (393 files) into that directory.  The unit has now been working fine for the past several hours now.  Both the skipping and the half-speed play symptoms are gone.

What have I learned during the last 10 hours?  Well…

  1. Possibly due to some FAT16 limitation, you cannot add more than 800 meg of MP3s (147 files) to the root directory of a FAT16 formatted 1 or 2 gig SD.
  2. Possibly due to some firmware limitation, the unit skips to the next MP3 in the middle of playing another MP3, and the unit plays the first song at power on, half-speed, when either a 1 or 2 gig SD is formated to FAT32 and loaded with 1.8 gig of MP3s (393 files).
  3. To load more that 800 meg of MP3s (147 files) on a 1 or 2 gig SD, the MP3s need be in a directory and not in the root directory.
  4. This is a great unit, my kid loves it and I am happy again, once I figured out its quirks.
  5. And finally in my two calls to SanDisk tech support they are very professional and without thier suggestions I would not have been able to solve my issues.  Keep up the good work!!!
    RevGary

Regarding your findings:

1: This is actually a limitation of FAT16 - and it has nothing to do with the size of the files or the size of the disk.  You just can’t have more than a set number of files in a FAT16 file system’s root directory.

3: This is exactly how you work around the aforementioned.  It’s also why most MP3 players have a Music folder at all.