Extreme Pro V2 4TB problem

i have a big problem. i use my second Extreme Pro V2 4TB con my iMac 2020 and on my new MacMini. the first one works well, the new one each time i connect it to the MacMini and back to the iMac (ejecting each time correctly) it result as ‘formatted’, empty and with the name “untitled”…
heeeeeelp!!! does anybody had the same problem? how can i fix it?
thx a lot


Hi @Yoghi,

Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting:

hi Kerrti_01
i sent the ssd back for warranty, it did the same just using it, turning the computer down and back on without removing the harddisk so i asked to send it back :slight_smile: thx a lot for your answer

I have had my drive Extreme Pro V2 4TB SSD fail two times now :frowning: I have submitted a support case. It looks like a very large number of people have had problems with this drive.


Hi @BenjaminGittins.

Thank you for contacting Customer Support regarding your issue with your 4TB SanDisk portable SSD. We are very sorry to hear that you are experiencing an issue with your product, and we remain committed to quality and reliability as our top priorities.

We will be more than happy to replace the affected product under the Warranty Replacement Policy. Warranty | Western Digital

Good afternoon I bought a SunDisk Extreme Pro Portable SSD 4TB Model: SDSSDE81-4T00, it worked for a month, during this time there were failures 2 times - computers stopped seeing the disk, as a result of this I lost a huge amount of very valuable information. I’ve only used SunDisk products all my life, but the most expensive product has let me down so badly. I wrote to the support service, sent a photo of the disc confirming the purchase documents, and they answered that I should create an online RMA request to confirm the replacement of the disc, but when creating a request, the system does not accept the serial number of the disc, it says that such a number will not be found . This already looks like a fraudulent company. The company probably does not manufacture its products at its own facilities, but uses the capacities of partners and cannot fully control the product quality processes and product testing. I came to this conclusion because many of my calls to the technical support service are ignored by the company, which, by law, must bear warranty obligations and responsibility for the product sold. Moreover, the cost of the purchased disc is 385 $USD. That’s a lot of money for me and I won’t just leave this disc without further attention from SunDisk. I would be grateful if a specialist will contact me to help resolve the issue of a refund or replacement of the product.

1 Like

Yup, happened to me last week as well. Came back to an edit the next morning and had missing media. Closed my NLE and ejected the drive, and then it was no longer able to mount. The very next day a 1st AC posted on IG about this issue. It’s very real. SanDisk owes a lot of people a new drive.

1 Like

Mine also was behaving strangely after few hours of copying on it so i unmounted it. plugged it in again and all the APFS volumes disappeared!! I tried to reach support team on the website but it get that the website is under system maintenance!
What a waste!

1 Like

Do confirm that the file system format of the external hard drive is compatible with both your iMac and Mac Mini. macOS typically supports formats like APFS, HFS+, and exFAT. If the drive is formatted in a different file system, you may need to reformat it to a compatible format.

Hi, of course it was formatted in exFat, like the second one… the problem is solved, they gave me a new one… thx