External SD


I have an Samsung 8GB Class 2 Micro SD card  that is not being recognised. Insreting the vard causes the “refreshing media” message to hang. If I remove the card a reinsert after media has refreshed I can format the card.

Using an external reader I can see that the card has not been formatted as the original contents of the card are still visible. I can format the card with FAT32 no problem. I am also using the latest firmware.

Anybody have any suggestions as to what the problem may be?

Unreadable ID3 tags is a good possibility.

Had already erased contents of internal and external memory as I had read about corrupt ID tags.

I tried a 4GB sandisk card which worked, however I guess this means the zip clip is not fit for purpose so I am going to return it via amazon as I do not want to take the risk of buying a larger SD card and finding it is not going to work.

Is there a list of tried and tested memory SD cards that work with the clip zip?

ID3 tags are part of the music, or audio files themselves. They have nothing to do with the SD memory card, no matter what size. In other words the problem is yours, not the hardware. I have used anywhere from 2GB all the way up to 32GB cards without issue with my Zip, as have many others.

If you don’t feel up to the task of fixing/editing your tags, by all means go ahead and return the player but be aware whatever you get to replace it may have the same issue as yours is not a problem with the cards nor the player.

As I previously mentioned I erased (by formating) the SD card so there were no music files and as such no ID3 metadata. As I also mentioned the 8GB samsung card works perfectly in other higher speed devices and as such can only be a compatability problem with the clip zip hardware or firmware either way it does not work.  A sandisk SD card 4GB however does work and as the memory is accessed in a serial manner SD/SPI mode we can assume that the IO must be working correctly for both types of card. This then only leaves supply voltage problems, logic threshold levels or SPI timing issues or firmware errors upon detection of the SD card type / manufacturer.

The bottom line is that if this and other cards work in every other device I have and not in the zip then it’s the zip. However this seems to be a common problem as doing some internet digging gave similar observations also Amazon gave me that impression when I spoke to them as they have sent me another device (which I requested instead of a refund) without charge or asked me to return the old unit.

It could assist to reformat the card using the SD Association’s Formatter tool, which can often help.  Available at the SD Association’s website.

Had already used the SD card formatter utility with no change in the behaviour.