ExpressCache problem: “A partition already exists"

I have a new installation of EC (W7. NET4.5, IE10, Asus Crosshair IV with RAID):

  • Disk installed properly, is in Device Manager

  • When I run the EC - answers, "A partition already exists on this drive. In order to use it as a ReadyCache SanDisk drive, you need to delete the current partition and run this application again. "

  • By EasyUse Partition Manager EUPM - I can check - partition is: 29.5 GB (partition type: other) + 300MB unallocated

  • I delete the partition EUPM … apply … (29.85G unallocated)

  • I run the EC - returns an error: there is a partition 29.5 (EC creates it and generate error?)

  • I delete the partition EUPM … apply … (29.85G unallocated)

  • I run the EC - returns an error: there is a partition (EC creates it)

(restart does not do anything)

I run from the command line:
c:\ eccmd -partition
It returns:
ECCmd exited with error 0x15 (21)

Where is the mistake?
zjk

What OS are you using? And can you post some screen shots of disk manager?

the only eccmd commands and parameter that is supported by the retail version of the software is eccmd -info. none of the OEM parameters are supported in this version. 

I wrote this: “I have a new installation of EC (W7 .NET4.5, IE10, Asus Crosshair IV with RAID)”

therefore - Windows 7 Pro

At this moment I can not do a dump - I’m on mobile,  but it looks good in disk manager (after partitioning with eccmd - but the same - even after error 21): the volume is visible, basic, online, healthy, size 29.8G, no letter (and any operation except the info/poperties you can not do on it).

Attempts to re-partitioning with eccmd - error, attempt eccmd formatting - error… I can delete partition with EaseUsPM - and repartition (with eccmd or EaseUsPM). And it is all I can do…

I have no idea.

:frowning:

“the only eccmd commands and parameter that is supported by the retail version of the software is eccmd -info. none of the OEM parameters are supported in this version.”

Mayby…

But command:

eccmd -partition

works well!!! It creates partition (without parameters like number disk or size) - correctly detects SSD!

and this despite the fact that I could not activate the EC!

EC from “pulpit” - create partition in bad size 29,5 GB (300 MB - unformatted).

eccmd - create partition with full size of disk - 29,85 GB

Remaining commands are working well too… (showing different errors - this issue can be OEM, but why did not give clear information, just “trying” to “do something”, and ends with an error - it is illogical)

You can look at this - is is Disk 4:

From polish language - Disk 4, primary, 29.82 GB, online, health, primary partition

From your disk management screen shot I can see a partition is on the SSD. The SSD should show as unallocated for EC to install correctly. You should be able to right click the disk where it shows the capacity and delete the volume. Once the SSD is unallocated then install EC. 

AS for the commands. As I said before they are not supported in the retail version. These are intended for OEM and developer use. Regardless if one command works or not it is not supported. 

drlucky: What you wanted - you got it :stuck_out_tongue_winking_eye:
You should you write in your post that you want to look partition before, after, etc.

But on the other hand - as important is the problem, “not clinging on to have vocabulary”.

  1. It is disk  AFTER removing the partition, BEFORE starting the EC. (screenshot shows DiskManager and EasyUse PM in the bottom of the window)

  2. It is disk  AFTER starting EC, you can see the partitions created by the EC 29,5 GB and left space 300 MB (screenshot shows DiskManager and EasyUse PM in the bottom of the window).

  3. It is disk  AFTER starting ECCMD, you can see the partitions created by the ECCMD (eccmd -partition) 29,85 GB and NO left space (screenshot shows DiskManager and EasyUse PM in the bottom of the window)

I performed alternately 1 and 2, 1, 2, 1, 2 - and there is no effect (with or without a reboot). EC creates partitions and at the same time I get the error that it already is, I delete it, I run the EC, which creates partitions and get the error that the partition is.

This is intersting as I have never seen this happen. Are you rebooting the PC after the partition has been deleted?

try this

1)      Delete the partition

2)      Reboot the system

3)      Verify that the partition is unallocated

4)      Reinstall ExpressCache

5)      Verify that the partition has been created

if you get the same error open up the command promt and run eccmd -info and post the results. 

OK

A. Delete partition, check (unallocated), reboot, uninstall EC, reboot, check, reboot, check (unallocated)

B. Run EC install - need reboot - OK, rebooting

C. BEFORE run EC (they ask - need to make changes in system - wait!), check - partition EXIST (29,85)! No reboot - EasyUS Partition Master below:

D. EC - OK, you can now made changes in system - error… “partition already exists”

E. Reboot, EC, error

F. eccmd -info -below

1.  Maybe partition is created in B. between install and reboot, I had no time to check this.

  1. The Apple partitions HFS/+ is a general problem of non-compliance (in Win). But in theory it should work. MacDisk (you know what it is?) - Disk doesnot have correct Macintosh volume descriptor.

zjk

I’m having this same exact problem. Any word on a fix?

I would be interested to know if, after the installation of ExpressCache and the subsequent reboot, if the partition is created and mounted. I have seen instances where, after the installation that the partition is not mounted and it was because of the lack of a reboot. Another thing to check is to make sure that the SSD is not part of the RAID. The SSD needs to be identified by the system and cannot be “behind” the RAID controller.

I figured out a solution to my problem, maybe it will work for you. I was going to uninstall and reinstall ExpressCache when I got an error that it couldn’t uninstall. So I started the install file and instead of uninstall I chose repair/modify(or however it’s labeled). That process finished sucessfully. I then deleted any partitions that had previously been created on the SSD, and then restarted the computer just for good measure. I ran ExpressCache again and it worked like it’s supposed to, formatting the SSD for use. So try repairing your installation.

Hey! :slight_smile:

No, it’s not that way, but thank you. At least in my case, maybe someone else will benefit from the advice. For me, restarts, re-installations (several), restarts did not help.

I will try to describe, what are the further life of the “fateful invention”.

Regards
zjk

With me, was going the same error …
I had swapped the ssd cache on my desktop (which was going well) to the laptop, then tried to make a NTFS Partition (to try), but when I tried to install the program was giving this error, then eliminated the Partition, ran again setup, repair done, and now already started to do well and this cache

I also have this problem… driving me nuts…

Component Details Subscore Base score
Processor Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz 7.1
5.5
  Determined by lowest subscore
Memory (RAM) 8.00 GB 7.7
Graphics Intel(R) HD Graphics 4000 5.5
Gaming graphics 1760 MB Total available graphics memory (Nvidia Optimus GForce GT 630M) 6.5
Primary hard disk 84GB Free (228GB Total) 5.8
Windows 8 Pro with Media Center
System  
  Manufacturer Acer
  Model Aspire V3-771
  Total amount of system memory 8.00 GB RAM
  System type 64-bit operating system
  Number of processor cores 2
Storage  
  Total size of hard disk(s) 450 GB
  Disk partition (C:) 84 GB Free (228 GB Total)
  Media drive (D:) CD/DVD
  Disk partition (E:) 95 GB Free (222 GB Total)
Graphics  
  Display adapter type Intel(R) HD Graphics 4000
  Total available graphics memory 1760 MB
        Dedicated graphics memory 128 MB
        Dedicated system memory 0 MB
        Shared system memory 1632 MB
  Display adapter driver version 9.18.13.2049
  Primary monitor resolution 1920x1080
  DirectX version DirectX 11 or better
Network  
  Network Adapter Qualcomm Atheros AR5BWB222 Wireless Network Adapter
  Network Adapter Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
  Network Adapter Microsoft Hosted Network Virtual Adapter
  Network Adapter TAP-Win32 Adapter V9
  Network Adapter Microsoft Wi-Fi Direct Virtual Adapter
Notes  
  The gaming graphics score is based on the primary graphics adapter. If this system has linked or multiple graphics adapters, some software applications may see additional performance benefits.
 
   

Initially had the installation problem

FileC:\Program Files\Condusiv Technologies\ExpressCache\SupportDll\ecbase.dll can not be found. Make sure the file is on target system or installed already.

removed the SSD and the program would start at leat and say no ssd installed.

shutdown pc.

entered bios

ssd showing (as before)

ran windows

ran ReadyCache.

program now runs but I get the " A partition already exists on this drive…" crap

Have reset internet explorer to defaults.

Have looked in regedit, can’t find problem mentioned about square or something on another page on this forum…

SO what to do?! I bought this ReadyCache today and am seriously thinking of taking it back unless SanDisk can sort it out!

Currently running a EasUS PArtiiton Manager Disk Wipe to see if that sorts out the problem… If it does I’ll post answer, otherwise you’ll not hear from me!

Anyone manage to sort this out in the mean time?

I had the same problem. Tested the readycache on a computer just to see if it worked. Then I put the ready cache in a newly build system. After installing ExpressCache I started the program. I also got the message that a partion allready existed. After I removed the partiton I still got the same message. The next steps dit solve my porblem.

  1. Remove the ExpressCache software from the system. And reboot.

  2. Use ‘clean all’ in disk part to erase all data on the ssd.

     - Start command prompt.

     - type ‘diskpart’ and press enter

     - type ‘list disk’ to get a list of disks in your system. Locate the ReadyCache disk (29G)

     - type ‘select disk X’ where X is the index number of the readycache.

     - type ‘clean all’ to erase the disk. (the whole disk wil be writen with zero’s. This will take about 10 minutes)

     - Type ‘exit’ enter and ‘exit’ enter to get back to the desktop.

  1. Now install ExpressCache again. And reboot the system.

After reboot ExpressCache worked for me. I hope this will work for some else to.

Running ExpressCache version 1.2.1 … ANYTHING YOU DO FROM HERE IS YOUR RESPONSIBILITY, I AM JUST A PUNTER & DO NOT WORK FOR SANDISK, CONDUSIVE TECHNOLOGIES, MICROSOFT ETC

Think I might have fixed this in Windows 8.1 64 bit… another “fix”. Look I do all of the above mentioned in this forum and sometimes it works/doesn’t but when I upgraded to Windows 8.1, with the SSD set up with ReadyCache from the old Windows 8 (working), when I installed ReadyCache in Windows 8.1 it installed first time no problem, even though there was a partition that was still set up to be used by my old windows 8.0. So I guess it just flat wiped it off (therefore telling me the problem was not on the SSD but left in my old Windows 8 “somewhere!”

Anyway after installing and removing drivers, windows updates etc  etc, after a while it said " delete partition/reset the cache due to hard drive blaa blaa blaa" ReadyCache stopped working on my new Windows 8.1 64bit & again I tried everything mentioned in this forum but nothing worked. Then… I had problems with my amd catalyst control center install & this was a solution to make that work so  I applied it here. This is what I did, some of it might be irrelevant but it worked!

  1. Make sure everything on your pc is upto date and all hardware drivers installed.

  2. remove ANYTHING that you don’t need pugged in, i.e. my Laptop I just have the normal spinning hdd and SanDisk ReadyCache SSD

  3. use Windows Control Panel “Programs & Features” to uninstall ExpressCache Software".

 

4)Don’t restart!

 

5)Ensure that in Windows Disk Management the Partition is “Unallocated”, if it’s not right click and click on delete volume.

  1. Run CCleaner and run the Registry cleaner & allow it to delete everything. (mine finds nothing?!)

  2. Go to your C:\Program FIles & C:\Program Files(x86) and delete any folders for Condusive Technologies

  3. Enure you can view hidden files and go to c:/Program Data (hidden file) and delete Condusive Technologies folder

  4. Go to C:\Users"yourname"\AppData (hidden folder) and again delete anything related to Express Cache, Ready Chache Condusive Technologies from the Local, Local Low & Roaming Folders.

  5. Then what I think works, & I think this is a problem with Windows and not Ready Cache Software… is do the following:

  6. click start button (if you’ve downloaded one!) &/or  in Windows 8 metro search for regedit

2)run regedit.exe and delete any references to express cache & or readycache & or condusive technologies from the software folders:
HKEY_CURRENT_USER\SOFTWARE
HKEY_LOCAL MACHINE\SOFTWARE

which on my pc running windows 8.1 64bit was…

HKEY_LOCAL_MACHINE\SOFTWARE\SanDisk\ExpressCache

  1. So delete that & exit Regedit.

  2. Turn off the computer normally

  3. I then removed the ReadyCache SSD (again not dsure if it had any affect?!) and restarted windows (with other external hard drives plugged in).

  4. Fully started windows and had a look in “Disk Management”… obviously my ReadyCache SSD isn’t there. my other hard drives are now listed as Disk 1, Disk 2 etc whereas ReadyCache used to be Disk 1.

  5. Exit Disk Management & Shutdown Windows.

  6. Connect up ReadyCache SSD & Restart Windows.

  7. Install ReadyCache Software and bing… no “This Partion is being used blaa blaa” & ReadyCache is working… now one more thing is it will sit at 0.7GB and you think it’s not doing anything… just wait. After about 5 mins eventually you’ll see it starts building the cache. IF after like 1/2 hour it isn’t just click on “Reset Cache” and wait again.

I hope this helps, like I say I have no Idea if 90% of the above is nescessary bit IT WORKED FOR ME… Maybe the guys at Sandisk can look at everything I’ve done and all the other solutions above & work out how to creat a propper fix for it!

I find ReadyCache makes a huge difference even on an ACER V3-771G with Intel i5 3210m & 8GBDDR3 Ram. Startup is rapid, programs opening are instant etc but remember it learns what you do/use and shoves that into readycache, so if you haven’t played a game for 1yr don’t expect readycache to have any effect. If you play it all the time it will be much much faster to load. & yes it is way better than readyboost & no don’t have readyboost on you don’t need it with this & don’t install AMD RamDisk as it does the same thing but not as well (& I think it might screw up ReadyCache!)

Cheers, Bye