expresscache 1.3 gui crashes win 8

hi

on my win 8 the expresscache 1.3 gui crashes i can see that exepresscache.exe is running i have uninstalled and installed still the same version 1.2 gui worked fine.

Happens in Windows 8.1 too.

8.1 pro 64bit

I can’t get version 1.3 to run in Win 8 at all. I installed 1.3 on top of 1.2.1. On reboot windows would not start, with an error of IRQL_NOT_LESS_OR_EQUAL. I was able to do a system restore to a previous point. This time I uninstalled 1.2.1 first, downloaded a new copy of 1.3 and ran it. Same problem. Computer works fine without 1.3. Won’t start with 1.3.

The IRQ not less or equal is usually a sign of a unstable system, due to overclocking, heat or some such.

Works for me on 8.1

I just installed 1.3 on 2 different systems, both running windows 7 home, 64 bit. On both machines the gui crash with the generic error of “Expresscache has stopped working” Show problem details displays:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: expresscacheapp.exe
Problem Signature 02: 1.3.0.0
Problem Signature 03: 526ad83c
Problem Signature 04: mscorlib
Problem Signature 05: 4.0.30319.17929
Problem Signature 06: 4ffa57ca
Problem Signature 07: 43c1
Problem Signature 08: 1b6
Problem Signature 09: System.IO.DirectoryNotFound
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 2ceb
Additional Information 2: 2ceb510a9d695168024ec606010fa90b
Additional Information 3: 1482
Additional Information 4: 1482501968821a078b0d496996ebe0e8

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

Event log shows this:

Faulting application name: ExpressCacheApp.exe, version: 1.3.0.0, time stamp: 0x526ad83c
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b8479b
Exception code: 0xe0434352
Fault offset: 0x0000000000009e5d
Faulting process id: 0xe1c
Faulting application start time: 0x01ced37766e792a0
Faulting application path: C:\Program Files (x86)\SanDisk\ExpressCache\ExpressCacheApp.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: a5cd26ee-3f6a-11e3-a85b-f46d04191b44

just before that error, there is this one:

Application: ExpressCacheApp.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.DirectoryNotFoundException
Stack:
at System.IO.__Error.WinIOError(Int32, System.String)
at System.IO.File.InternalCopy(System.String, System.String, Boolean, Boolean)
at DKC.EC.UI.CodeHelper.CopyECDlls()
at DKC.EC.UI.ExpressCacheApp…ctor(System.String)
at DKC.EC.UI.Program.Main(System.String[])

On 1 machine i upgraded from 1.2, on the other from 1.1. On both i did a full uninstall, rebooted, removed any instance of expresscache from the registry, rebooted and reinstalled to recieve the same error.  I’ve also uninstalled .net 4.5 and installed 4.0 as a test, same resulting error, installed 4.5 again and patched, same error.

I saw a solution on here about an internet zone in the registry, but that entry is not on either of these systems.

Service seems to run fine, and it seems to using the cache.

any help would be appreciated.

Update to previous post, caching does not seem to be working at all, so i had to rever to the last installer i had downloaded which was 1.0.1, caching is now working.  Does anyone have a download for 1.2.1?

Can you open a command line window (in administror mode) and type:

eccmd -info

please write the outpout on your response.

Thanks

i get this from eccmd -info (cmd in administror mode)

C:\Windows\system32>eccmd -info
ExpressCache Command Version 1.0.108.0
Copyright® 2010-2013 Condusiv Technologies.
Date Time: 10/28/2013 21:13:4:475 (xxxxxxxx #0)

Failed to retrieve product license information.

cheers kreto

Here is the output, I’m not able to re-install 1.3 right now, as soon as i can i will and then rerun the command.

ExpressCache Command Version 1.0.94.0
Copyright© 2010-2012 Condusiv Technologies.
Date Time: 10/28/2013 16:44:0:753 (SATYR #3)

EC Cache Info

Mounted : Yes
Partition Size : 29.82 GB
Reserved Size : 3.00 MB
Volume Size : 29.82 GB
Total Used Size : 11.92 GB
Total Free Space : 17.90 GB
Used Data Size : 11.85 GB
Used Data Size on Disk : 11.91 GB

Tiered Cache Stats

Memory in use : 1024.00 MB
Blocks in use : 8188
Read Percent : 17.32%

Cache Stats

Cache Volume Drive Number : 0
Total Read Count : 21249
Total Read Size : 1.74 GB
Total Cache Read Count : 4334
Total Cache Read Size : 110.32 MB
Total Write Count : 45077
Total Write Size : 1.04 GB
Total Cache Write Count : 36662
Total Cache Write Size : 223.05 MB

Cache Read Percent : 6.18%
Cache Write Percent : 20.94%

Kreto, Your ExpressCache software was not installed properly.

Try to uninstall and install from scratch. You can download the latest version from www.Sandisk.com/ReadyCache

When you uninstall, select ExpressCacheApp, not ExpressCache.

Chritensenr, Try to just uninstall ExpressCache completly from your machine, download version 1.3.0 from www.sandisk.com/ReadyCache and install. Do not select “Always start …” option and reboot your PC twice. After that, try to run “eccmd -info” again.

Let me know…

For those having issues with 1.3.0, please do the following:

  1. Uninstall 1.3.0

  2. Reboot

  3. Open a CMD window and type %tmp%. Note the path then navigate there using exlporer and delete all files in that folder (skip any files/folders that say they cannot be deleted).Should be something like: C:\Users\<your login name>\AppData\Local\Temp

  4. Reboot

  5. Re-install 1.3.0

  6. Reboot

Let us know the results.

Thanks!

@gls and @georgealon

Uninstalled and re-installed as instructed, and it is now working on both machines.  It is fully caching, boot times are speedy again.  below is the output.  Thanks for help!

ExpressCache Command Version 1.0.108.0
Copyright© 2010-2013 Condusiv Technologies.
Date Time: 10/28/2013 21:20:17:332 (SATYR #3)

EC Cache Info

Mounted : Yes
Partition Size : 29.82 GB
Reserved Size : 3.00 MB
Volume Size : 29.82 GB
Total Used Size : 2.97 GB
Total Free Space : 26.85 GB
Used Data Size : 2.90 GB
Used Data Size on Disk : 2.96 GB

Tiered Cache Stats

Memory in use : 1024.00 MB
Blocks in use : 8188
Read Percent : 2.88%

Cache Stats

Cache Volume Drive Number : 0
Total Read Count : 51297
Total Read Size : 1.16 GB
Total Cache Read Count : 34479
Total Cache Read Size : 662.38 MB
Total Write Count : 7244
Total Write Size : 79.06 MB
Total Cache Write Count : 1683
Total Cache Write Size : 10.51 MB

Cache Read Percent : 55.76%
Cache Write Percent : 13.29%

This is great news.

Enjoy caching!!

:heart: georgealon thanks i works now…Uninstalled and re-installed as instructed

now i get this from 

C:\Windows\system32>eccmd -info
ExpressCache Command Version 1.0.108.0
Copyright® 2010-2013 Condusiv Technologies.
Date Time: 10/29/2013 20:52:30:509 (xxxxxxx #2)

EC Cache Info

Mounted : Yes
Partition Size : 29.82 GB
Reserved Size : 3.00 MB
Volume Size : 29.82 GB
Total Used Size : 956.75 MB
Total Free Space : 28.88 GB
Used Data Size : 880.50 MB
Used Data Size on Disk : 948.25 MB

Tiered Cache Stats

Memory in use : 768.00 MB
Blocks in use : 6126
Read Percent : 0.13%

Cache Stats

Cache Volume Drive Number : 0
Total Read Count : 15790
Total Read Size : 1.03 GB
Total Cache Read Count : 118
Total Cache Read Size : 5.23 MB
Total Write Count : 2647
Total Write Size : 81.89 MB
Total Cache Write Count : 155
Total Cache Write Size : 1.17 MB

Cache Read Percent : 0.50%
Cache Write Percent : 1.43%

C:\Windows\system32>

and agian thanks for the help georgealon

cheers kreto

Kreto, you are welcome!

After reading some of the suggestions on getting 1.3 software to work, I deleted all my temp files, removed the registry entry, downloaded a new copy of the software and, after a fresh boot, installed it. Windows was unable to start up again. Same IRQL error as before. The system works great and has no stability issues without the 1.3 software. Install 1.3 and it’s as useful as a brick.

This time I enabled windows installer in safe mode and uninstalled the 1.3 software. Voila, windows boots fine again. This is clearly a compatibility issue in my system.

I’ve got a RAID 10 array (4 drives) and 2 DVD drives connected to the Intel SATA ports, and the ReadyCache connected to the Marvell controller on an ASUS Rampage III Formula motherboard.

Unfortunately I deleted the old software before I downloaded 1.3, so for now - no cache. It’s a shame, because I really appreciated it before.

Can you post the memory dump and or event viewer log? 

I believe I have figured out the culprit - the Marvell drivers are the latest ones listed on the MB support page, and having “update driver from net” search says they are the most current, but they’re pretty old. I found a much newer version - no thanks to Marvell which seems to consider up-to-date drivers to be trade secrets. I bit the bullet and got them off station-drivers.com after some endorsements from other individuals that have tried them, and this seems to be a much happier system now.

Basic answer - check the Marvell drivers if anyone is having similar issue. While not directly related to ReadyCache, I was able to find several other folks having SSD glitches with the Marvell SATA ports.