Error in IOCTL call error while formatting SanDisk Cruzer POP 8GB new pen drive

SanDisk Cruzer Pop™ 8 GB USB Flash Drive IOCTL Error while formatting.

here is sample output:

C:\Users\Dell>format g:
Insert new disk for drive G:
and press ENTER when ready…
Error in IOCTL call.

Also shows same error formatting from GUI Screen.

I appricate quick response for the same. 

:smiley:   Hi Ganesh1111,

Dear member of SanDisk Community, welcome.

Excuse us, for delay in answer you, but your message was lost in another section, and newly it I found.

The DeviceIoControl function provides a device input and output control ( IOCTL ) interface through which an application can communicate directly with a device driver.
The DeviceIoControl function is a general-purpose interface that can send control codes to a variety of devices.

Each control code represents an operation for the driver to perform.

For example, a control code can ask a device driver to return information about the corresponding device, or direct the driver to carry out an action on the device, such as formatting a disk.
A number of standard control codes are defined in the SDK header files. In addition, device drivers can define their own device-specific control codes. For a list of standard control codes included in the SDK documentation, see the Remarks section of DeviceIoControl.
The types of control codes you can specify depend on the device being accessed and the platform on which your application is running.

Applications can use the standard control codes or device-specific control codes to perform direct input and output operations on a floppy disk drive, hard disk drive, tape drive, or CD-ROM drive.  

If you have further questions, you can check here:

Very clear, of course….

Well, in short summary, is it following:
The most common use of IOCTL , is to control hardware devices.

I assume, you tried the UFD, in other PCs, to define the problem.
If the UFD is wrong in other PCs, return it, and ready.

But if is your PC, I will give you four suggestions:

1- Try others UFD (USB flash drives) on your PC, and see what happens.
2- If the problem, then, is of some corrupt line, in the registry / USB of the PC, please, then we will use, two small portable applications (free), are third party tools, very simple to use:

     - CCleaner 4.10          

     - USB Scrub Cleans 1.00

Then, analyze the following:
- In the _ Control Panel / _ Administrative Tools / Event Viewer: see if there is information on this item.
- See also, in the Task Manager, the processes which are running, and see what are the necessary and what to delete. Because, there are some programs, that cause, system conflicts, by blocking the ports, such as: Samsung Kies, HTC Sync, etc.
- In the Control Panel / Administrative Tools / Computer Management / Device Management Tools: see if a USB icon is crossed out with red , or there is a yellow question mark, etc.
See, also, for a teaching with images, the links:

3- Watch a “System Restore Point”, before the problem. If still bad:
4- To check the PC, for some excellent Technician.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                            (Google translated)

Hi Ganesh, sorry to bumo this up but I was just wondering if it was a PC issue for you? How were you able to get this to work?