I/O error on a 16GB SanDisk Cruzer Contour USB

Dear all

I bought a 16GB SanDisk Cruzer Contour USB stick nearly three years ago. It worked always fine until now. I never used any U3 utilities only the data drive. I only moved files from and to the data drive. From one day to the other the:

E:\ is not longer accessible.

“The request could not be performed because of an I/O error”.

While the F:\ CD drive with the U3 stuff is still accessible and readable.

I tried every kind of utility from disk managers to partition stuff, from Dos, Linux, Windows, tested it with different notebooks and workstations running Windows XP, Linux. I also disabled the Virus protection, without any success :angry:
I don’t know how U3 technology works and influences this product exactly, but I think it is the “driven factor of this problem”, as reported in many forums. However I tried also to disabled the F:\ CD drive in the device manager and the U3 uninstaller tool from SanDisk also failed with an I/O error.

Any other or new suggestions?

Thank you very much indeed for any feedbacks.

Regards Walter

Zurich, Switzerland

I doubt U3 has anything to due with your I/O problem, it sounds hardware related not software.  I suspect a wire or solder joint as become oxidized or broken.

On my windows 7 I am getting IO errors. What should I do next. This is a 16G chip for my LG cell phone,

Happiness

One is always on a strange road, watching strange scenery and listening to strange music. url=[http://www.edmontonasianescort.com/]Edmonton Escort[/url] Then one day, you will find that the things you try hard to forget are already gone. url=[http://www.edmontonasianescort.com/]Edmonton Escort[/url]
Happiness is not about being immortal nor having food or rights in one’s hand. url=[http://www.edmontonasianescort.com/]Edmonton Asian Escort[/url] It’s about having each tiny wish come true, or having something to eat when you are hungry or having someone’s love when you need love. url=[http://www.edmontonasianescort.com/]Edmonton Asian Escort[/url]