e280v2 frozen - stuck refresh database

Looking for a clue here…

My e280v2 corrupted itself to the point where upon powering up, it get stuck in the refresh database window.  Can’t do or access anything.

How do I reset the beast?

For the time being, I can only power it on and off…

Can’t beleive I’lost  7 GB of MP3, video and recording.

Anyone?

Thanks

Connect in MSC mode and run ChkDsk. It may be able to find and/or repair whatever is causing it to hang up.

Although the problem could be tag-related . . . When the player freezes during the database refresh, it usually means it’s encountered an ID3 tag it cannot read.

I would very much be able to connect it in MSC mode, but I can’t access anything…  It is frozen in the refresh database window…

Follow the “Force MSC mode” instructions here.

It worked!!!  Thanks a lot :slight_smile:

I guess you are right about faulty MP3 ID tags…

My e280v2 is back to life, thanks to you.

I feel I have the latest firmware:  v03.01.16A.  Before triyng an upgrade, I will chech my files.

Thanks again

Glad it worked for you!

v03.01.16 firmware is the latest & greatest so it seems you’re good to go. :smiley: