E250 v2 displays "Refresh Database" at every start up now?

I have an e250 v2 (2 gb). I also have an external SanDisk 4 gb Micro SDHC memory card. I’ve been using the micro SD card for more than a year now. The player has worked beautifully for 2 years, up until now. I download music from Napster (I pay the montly fee) and I also load songs via Windows Media Player. My PC is running Vista. Up until yesterday all was good.

When I plug my e250 into my PC via the USB cable, Windows Media recognizes the player, but it is no longer able to delete songs from the Micro SD card. I am able to delete songs from the players internal hard drive still though. Also, at startup, the Refresh Database screen comes on every time now. It used to come on only after I removed the USB cable after charging or downloading new songs. After the Refresh Database screen goes off, the player works fine. I thought about reformatting the player, but I do have LOTS of songs currently installed. Maybe this is why it has started this? Should I completely clean off both the internal hard drive and the SDHC card and start over?

First try going to Settings and changing USB Mode to MTP.

Are you transferring subscription media (with DRM) to your device?  If so, no doubt, you need MTP mode for license transfer.  MTP mode does streamline the “refresh database” issue.  With the v1 e200s, the database refresh is an issue when the microSD card is mounted, using MSC mode.

In your case, let’s make a quick check of the e200 version.  When you power up your lil monsta, do you see a blue sansa logo below the SanDisk logo?  This is confirmation of a v2 device.  Otherwise, you can go to Settings > Info and read the top line of the screen: if the installed firmware version begins with “01” you have a v1, if “03”, you have a v2. 

The v2 device should not refresh the database upon startup, unless there has been a data transfer.  If the microSD card is swapped, even if the power is turned off, the Sansa will refresh the database upon power-up.  The lil monsta never sleeps, you see.  I am suspicious of an expansion card issue, if you have a v2.  If we have a sporadic connection, or if the card is removed / reinstalled, remember that the v2 will refresh when started.  The same thing will happen if we have a dirty or erratic connection, which can usually be resolved simply by removing and reinstalling the card.

You can try removing the card, then cycle the power.  See if the device no longer refreshes every time you power up.  Your issue may just be with the card.

Bob  :smileyvery-happy:

Thanks for the replies!

c1u31355…my player doesn’t have the option to change the USB mode in the settings menu. I’ve read elsewhere that version v2 doesn’t have that ability…?? How do you find out if the player is in MTP or MSC mode?

neutron_bob…thanks for the info. Yes, I have the little blue sansa logo underneath the SanDisk logo at startup and my installed firmware version is V03.01.11A…blue sansa and 03 equals v2. My player displays the “Refresh Database” at every start up. It doesn’t matter if the external Micro SDHC card is installed or not. It also doesn’t matter if the player has been plugged into the PC or not…it does it EVERY time. Is there a firmware update available for the v2 players? Would reformatting (erasing everything on it) help? I don’t care if I lose everything I’ve got downloaded to it, I just want it to work!

Look under Settings/System Settings. I have a v1, but if v2 is like the Fuze, that’s where USB Mode is. 

Only the first firmware for the v2 didn’t have the mode switch. Look at the sticky, near the top of the E200 page,  to update the (v2) firmware. Don’t install the updater–follow the manual instructions. There won’t be any more updates, so you’ll be installing the last firmware. 

After you install the firmware, find USB Mode and change it to MTP if you’ve been using Windows Media Player. 

I don’t have a “system setting” under the main Settings menu. On another thread I think I read that the v2 players don’t have the “system setting” option? Is there a more current version available of the firmware or is V03.01.11a the most current?

My son has a 4gb Fuze and his has the “system setting” on the main Settings menu.

3.01.16 firmware

Only the very first v2 firmware, 3.01.01, did not have the USB mode switch. It should be in there somewhere already. Or maybe it just says Mode.  

I believe I’ve got my player restored to normal. I uploaded the latest firmware, version V03.01.16. After I did that, it still displayed the “Refresh Database” at every startup. Next, I formatted the internal memory and my external Micro SDHC card. This erased all the songs I had on the player, but it fixed the problem. I’m guessing I had a corrupt file or two??

Also, with the new firmware version, I now have the ability to change the USB mode. I have Auto Detect, MTP and MSC as choices. In earlier responses I was told to make sure it was in MTP mode. Is this correct?

I know it’s a different player, but my son’s Fuze is set on Auto Detect.

Thanks for the help!

Rustang87 wrote:

I believe I’ve got my player restored to normal. I uploaded the latest firmware, version V03.01.16. After I did that, it still displayed the “Refresh Database” at every startup. Next, I formatted the internal memory and my external Micro SDHC card. This erased all the songs I had on the player, but it fixed the problem. I’m guessing I had a corrupt file or two??

 

Also, with the new firmware version, I now have the ability to change the USB mode. I have Auto Detect, MTP and MSC as choices. In earlier responses I was told to make sure it was in MTP mode. Is this correct?

I know it’s a different player, but my son’s Fuze is set on Auto Detect.

 

Thanks for the help!

Bingo!

Don’t ever use the Auto Defect USB setting. If you run DRM-encrypted content like Rhapsody, or Audible/overdrive audio books you have to use MTP mode. If not, it can cause more problems than it’s worth, unless you really want to ‘sync’ with WMP. MSC mode makes your player appear to your computer as just another simple ‘drive’. It will be listed in Windows Explorer as 2 separate drives, each with their own drive letter. The 1st one will be the playert’s internal memory; the 2nd will be the card slot. This happens whether there’s a card inserted or not. Now you just can drag & drop your files to your heart’s content.

MSC = M ode of S ansa C hampions. :smiley:

Rustang87 wrote:

I believe I’ve got my player restored to normal. I uploaded the latest firmware, version V03.01.16. After I did that, it still displayed the “Refresh Database” at every startup. Next, I formatted the internal memory and my external Micro SDHC card. This erased all the songs I had on the player, but it fixed the problem. I’m guessing I had a corrupt file or two??

 

Also, with the new firmware version, I now have the ability to change the USB mode. I have Auto Detect, MTP and MSC as choices. In earlier responses I was told to make sure it was in MTP mode. Is this correct?

I know it’s a different player, but my son’s Fuze is set on Auto Detect.

 

Thanks for the help!

Bingo!

Don’t ever use the Auto Defect USB setting. If you run DRM-encrypted content like Rhapsody, or Audible/overdrive audio books you have to use MTP mode. If not, it can cause more problems than it’s worth, unless you really want to ‘sync’ with WMP. MSC mode makes your player appear to your computer as just another simple ‘drive’. It will be listed in Windows Explorer as 2 separate drives, each with their own drive letter. The 1st one will be the player’s internal memory; the 2nd will be the card slot. This happens whether there’s a card inserted or not. Now you just can drag & drop your files to your heart’s content.

MSC = M ode of S ansa C hampions. :smiley:

The original message mentions Napster. That means MTP.

The e200 series v2 was originally shipped with firmware 03.01.11.  This firmware build did not include the USB mode option; essentially, the player was set up as an MTP only device.  You can manually force an  MSC mode connection by holding the << button depressed (HOLD switch also set to the right, orange showing, and power OFF when plugging the sevice in to the USB socket).

The “secret handshake” method above is handy if you have a frozen device, and cannot establish a USB connection.

It is not normal for the v2 to go through a Refresh Database step on startup, unless the device memory has been addressed by the computer, and any transfers have been made.  In MTP mode, if the device is simply plugged in to charge, as long as Napster (as you mention) or Rhapsody haven’t made a license update, you should not have a database refresh.

Simplified database management is one of the advantages of the later e200.

If you want to first try a solution without having to format the device, you can select MSC mode, and check the drive for errors, using the manage function in Windows (start by right clicking on My Computer in XP).  Here’s a cool visual guide to the procedure, if you’ve never used the chkdsk command from Windows.  The Knowledge Base entry is for a FAT corruption issue, but the Error Checking part is what we’re interested in.

Next in our troubleshooting procedure is the music database itself. In MSC mode, navigate to the root directory of the e200 using Windows Explorer (My Computer).  Go ahead and delete the mtable.sys file.  This is the music database. The Sansa will build a new one from scratch when disconnected.

If the database continues to continually refresh on power-up, I would first be sure that you have backup copies of your music, then go ahead and use the Sansa’s built-in Format command (listed under Settings) to clear the player’s memory.  Using Napster or Rhapsody services, you’ll need to reauthorize the device using the subscription client on the computer.  Then, retransfer your music.  This is the “nuclear option”, and it should do the trick.

The e200 v2 is unique among the AustriaMicrosystems equipped Sansas, as it doesn’t have the additional submenu “system settings” as you’ve noticed.  We get to go straight to the system options in one large menu.

Let me know if this solves your database refresh issue!

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 03-27-2010 07:32 PM

neutron_bob wrote:

The e200 series v2 was originally shipped with firmware 03.01.11.  This firmware build did not include the USB mode option; essentially, the player was set up as an MTP only device.  You can manually force an MTP mode connection by holding the << button depressed (HOLD switch also set to the right, orange showing, and power OFF when plugging the sevice in to the USB socket).

 

The “secret handshake” method above is handy if you have a frozen device, and cannot establish a USB connection.

Didn’t you mean MSC, Bob?

Thanks to everyone who helped me! My e200 v2 is back to normal. I uploaded the latest firmware, reformatted both the internal memory and external Micro SDHC card. I was a little confused about which USB mode to put it in. One person says MSC and another says MTP. I tried them both and for Windows Media Player and Napster to recognize my player, it needed to be in MTP.

It no longer displays “Refresh Database” at every start up. That message only comes on after I charge it or download new songs to it and that’s how the player has worked for the 2 years I’ve had it.

Thanks!

I corrected my post to reflect MSC , thanks, Tape!

I’m glad to see that your Sansa v2 is back to normal.  The v2 has quite a few little differences from the v1, features common to the latest generation of Sansas.  I chose the v2 for its Audible capabilities, that I learned to love on the little Clip.

The database refresh is streamlined when using MTP mode, a bit faster.

Bob  :smileyvery-happy: