E280 WhiteScreen

Hello. I am aware that there is probably a thread already out there with the answer cry for help but I’m not very good with computers and nothing has been useful to me yet.

So here’s my problem : I have an old Sansa model e280 (what’s written on the back) and I’ve tried a few ways already to get it working again but nothing worked (as I said, not really a computer guy :S).
Here’s what I’ve tried :
Pulling out the battery for a while,
Reformatted my mp3,
and downloaded the Sansa Updater (Wich doesn’t recognize my mp3 (I can see it plugged when I open ‘‘My Computer’’)).
That’s pretty much it. Please help!
Explain it as simple as possible

P.S. : Just tried an answer that was chosen, did not work (With the sansa.fmt notepad texts)
altough when I recovery, I see the 16MB file. I might be doing sum wrong tough.

Message Edited by Frank171093 on 04-16-2010 08:24 PM

This is driving me insane, please help! Been looking on the web forever

A white screen, on a Sansa e200 series, is a very rare occurrence. As you have Recovery Mode, this confirms that you have a v1 device with the PortalPlayer processor.

With a little patience, you can get this wee beastie running again, as long as you’re methodical.  Time to brew some coffee.

Did you format using the sansa.fmt file / folder method ONLY?  If so, this is fine.  When in Recovery Mode, the reserved partition is open, and you must be careful to never use the Windows format command from the PC on this partition.

Let’s do the most simple test first: remove the back plate of your e200, and check the memory board.  Above the battery module, you will see a plastic black rectangle.  Within this space, there’s a grey foam block.  Press downward gently on this block to reseat the memory module to the main circuit board.  If you heard a soft “click”, you’re on your way!

Reinstall the battery module and the rear cover, and see if the Sansa will start up normally.

The firmware is stored in the flash memory module.  If it was loose, the player cannot boot successfully.

Let us know what you have at this point.

Bob  :smileyvery-happy:

I did all that but I think I might’ve formatted with the PC command, had white screen before and nothing changed :S hope I didn’t screw something up. I did remove the back and push on the block. and put an empty sansa.fmt file in my 16mb E: thingy.