e270 blue ring lights, no screen display, not recognized

This is an e270 version 1.  I don’t know the firmware version since it won’t show anything.  The screen is blank but the ring lights up.  I tried the updater but it won’t install unless Vista recognizes the device and Vista don’t.  Then I downloaded the zipped firmware files.  I plugged the e270 into my linux machine and it mounts the partition where the music files are on /media/Sansa.  I can see and copy out the music files.  I put the two firmware files in the root of the mounted drive but they seem to have no effect.  The screen on the e270 stays blank after a 15 second reboot.   A strange thing is that though I can mount the device and access files on linux, gparted the disk partition software does not see the device.

Blue Ring of Death fix

In the answers link:

I downloaded the Sansa Updater and it didn’t detect the device and won’t install unless it does.

I tried the e250 firmware updater with similar result.

Tried the DeviceRecoverySetup and it failed to install with an error DPINST RESULT: [-2147483648]

I should have mentioned Vista is asking for a Tango Player driver update when I connect but I wasn’t positive it was related to the Sansa before.

That blue ring of death link doesn’t have much help. It amounts to a link to a linux source code for a recovery program. I’d really rather avoid trying that if possible. It says to enter manufacturing mode by pressing the center button and more recent Sandisk instructions say to hold down the record button.

The message from Windows, looking for the Tango Media Platform, is a reference to the firmware image needed for the PortalPlayer (now NVIDIA) processor used in the v1 e200 machines.  Tango refers to this original device firmware.

Manufacturing Mode is different from Recovery Mode.  Pressing the center button is used for restoring the I2C ROM firmware needed for the Sansa, which is done using the e200tool software (the Linux platform is needed for this process, there was apparently a Windows version at one time, but it was unstable).  Be sure to keep the button depressed at the point described in the e200tool process.

I always mention pressing the rewind << button when instructing folks about the manual MSC mode process, for the simple reason that if they are using a v1 (PortalPlayer) device, pressing the center button enables Manufacturing Mode, which we don’t need for that situation.  The v2 devices are happy to respond to the center button, as they have a different processor and no Recovery Mode.

An important quick note regarding the reserved partition.  If the Sansa will not boot, it’s entirely possible that a mechanical connection to the flash memory daughterboard can cause serious headaches.  To check this, remove the rear cover, and inspect the big black rectangle above the battery module.  You’ll see a grey foam block there, which keeps the daughterboard pressed inward.  Go ahead and give it a gentle press.  If the board clicks back down into its socket, you may have just solved your problem.  Back to our regularly scheduled program:

There are several good descriptions of the process needed to recover your device using the e200tool utility…I did a wee bit of searching, had to run to another computer that had the information for you.  Check this blog about fixing the Sansa with e200tool.  Of all the descriptions I’ve seen, this visual one is pretty cool.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 04-17-2010 06:47 PM

Thanks Bob for your informative and helpfulness.  I did not understand what the manual MSC mode was and I didn’t check for the mechanical connection thinking that since ubuntu can access the data partition it’s OK.  Finally I did not understand Checktook (in the last paragraph) but I did find the blog link easy to follow along.    

I followed the steps on two different machines, two distributions of ubuntu 9.1 and got the same results.  At the point where the blog says “notice the scroll wheel blinks once” it did not blink though the recover command did report completely every line and “Execution started!”.  The partition did not automatically mount nor was I able to see it with gparted nor in /media.  I was still able to access the data files. 

The only discrepancies I noticed were when I connected the Sansa and typed lsusb.  The result was:    

Bus 002: ID 0781:0720 Sandisk Corp.  Sansa C200 series in recovery mode.  

I can’t check the screenshot of the output on the blog, my browsers won’t make it readable with any magnification, but shouldn’t it be E200 instead of C200?  I should have mentioned before it’s “remanufactured”.   The only other thing was in the output of the e200tool recover command.  In the line that reports

          Searching for device xxxx.xxxx … 9 found!

 it writes

          Searching for device xxxx.xxxx … 9 8 found!

Thanks again for the help.  I’m sorry it took me so long to get back to this.  Will have to check on the warranty period.

Hehe, I just noticed the typo.  My thumb touched the track pad, and the word “took” was dragged into the post.

If I understand correctly, you have an illuminating blue ring without a successful boot.  Regarding the memory daughterboard, be sure to check it as a loose module can cause all sorts of mayhem.  The Sansa bumps about in normal operation, as compared against sitting on the desk with a cable plugged in.

There are two modes mentioned in the e200tool recovery process, Recovery Mode and Manufacturing Mode.  There is a point in the process when you need a bit of coordination, keeping the button pressed while writing to the device.  It’s been a while, I’ll look it up again later tonight.  I don’t have a v1 device on hand at the moment to retest.

Bob  :stuck_out_tongue:

Thanks, I’ll check back later.

Just letting you know the warranty period was almost complete so I had to return it.  Thanks again.

Already tried this too. I’ve pressed the grey thing, it seems to get back in place but then…nothing


Thank you so much for your mentioning regarding mechanical connection to the flash memory daughterboard

When I got that bluewhell of death, I prepared for long manipulations with flashing device in manufacturing mode, but luckily that was enough to gentle press the piece of foam above the battery. After that device booted normally. :smileyvery-happy:

The story was: my device had hang up after I accidentaly pressed record button while listening to music. The usual Recording screen appeared, but with no stop or pause items. Power button did not respond, neither one of others, so I had to remove back panel and remove the battery, after which bluewheel got in place, and Windows seen only Tango Media Platform instead of Sansa.