e260R no longer recgonizing WMA audio books

I’ve been using my E260R for several years to listen to WMA audio books dowloaded from Overdrive.  A few weeks ago the book stopped mid chapter and gave me an error message about my licence expiring (which it hadn’t). 

I erased all the files, tried downloading again but now the player gives me an error message that says "the format of this title (WMA audiobook) is not compatible with this player is not compatiple with this Sansa Sandisk E260R USB devise K:.  I can still dowload MP3 audio books, but not WMA.

So, I’ve tried formatting the player. no luck.  I’ve tried updating it.  no luck.  Infact, in doing all of that my computer doesn’t even recogize my player as a portable audio devise anymore.  It just calles it “k” drive.

I have Wonwos 7.  I have media Player 11 ( but I’m not sure if that matters sinc emost of the time I’m just pulling the audio book directly from Overdrive). 

How can I get my Sansa e260R to play WMA files again?!

Go into Settings > USB mode and change it back to Plays For Sure , which is MTP mode. It needs to be in this mode to transfer the license info on DRM-crippled files like your WMA audio books.

Ok great.  This helped with having my Sansa recognized again.  Now I’m getting a different message when attempting to dowload a WMA audiobook.

  “An error occured when atempting to transfer “book title.wma”   Error details: unable to transfer selected title.  Error 0xC00D27712:  A problem has occured in obtaining the device’s certificate. Contact Microsft product support.”

The licence should be fine.  I just downloaded the book a minute before.


Did you use the Overdrive Console to download _ and _ transfer it to your player?


Probably need to format the player and start over.

And remember to check the USB mode afterwards; formatting can change it too. :wink: