audiobook (DRM) on e250


I’ve got a problem with my Sansa e250: I can’t get audiobooks with DRM-licence (from my library) going. The player always says “synchr. to continue your abonnement” (i.e. the german equivalent), though I’ve got the licence from the library and put the audiofile (WMA) on the player using WMP 11 (synchronisation). I choose the USB-Modus MTP. I tried MSC as well, but WMP always said “error” when I tried to use the synchronisation. I even tried drag and drop, but that (unsurprisingly, I suppose) didn’t work eather.

(I’ve got the version of e250 which hasn’t got a radio; a friend of mine has got the one with radio and for her, DRM works perfectly fine.)

I would be extremly grateful for any help!!!


(Sorry for the bad writing; English isn’t my mothertongue.)

Your English is pretty good!

Does the audiobook from the library have a special manager application?  This may be needed to transfer the correct license.

For example, Overdrive is a common library audiobook manager used in the US with local libraries.  Overdrive uses an earlier variant of the DRM-10 system than Windows Media Player uses (Janus system).

The player may need to be authorized forat using the specific client (manager) for the audiobook version.

Bob  :smileyvery-happy:

Dear Bob,

thanks a lot for your answer!

I don’t think that my library (a local german library) uses a special manager application (though I’m not a 100% sure, for I’m not very good with all this technical stuff). I was able to download audiobooks and to synchronize (is that actually an existing verb?) it using WMP 11 on an e250 v2 of a friend of mine some days ago. But now it won’t work with my e250 v1…

Could the WMP cause the trouble? Because I noticed (finally…), that, when I try to synchronize the file on the player, there is an info-icon next to the file saying something like “you need further rights for synchronizing this file…”. I can play the audiobook on my PC though and I’ve got the licence too, which allows me to put the file on any portable mp3-Player as well. So could it be, that the WMP doesn’t realize I’ve got the licence to synchronize the file? (I used WMP for the player of my friend though, too - but maybe something changed during some automatical update?)

But maybe I’m totally mistaken and the problem is caused by the files itself… It’s just strange that it did work some days ago with the other player…

Maybe you can make something out of this?

(If it was a problem with the player afterall: How would I get it authorized for using the manager?)

I would be really happy if you could help me!


As an example, audio books from Overdrive need to be transferred using the Overdrive Media Console application.  Once this is done, the license information is transferred to the player with that first book.

Using Windows Media Player, the WMDRM-10 system can transfer the license as long as the player is communicating in MTP mode.

With the e260, on the player, select the Settings mode from the main menu, the “equalizer-like” icon.  Scroll down to USB Mode, and then select MTP.  The player will then communicate in MTP when plugged in.

In WIndows,if you test the player by opening a WIndows Explorer window, the player will be seen as a media device.  It will appear as Sansa e260 (without a drive letter assigned to it).  If you double click on this, you will see Internal Memory and External Memory.  Close Windows Explorer.

THen open Windows Media Player, and you should see the e260 listed with Internal and External memory.

If you select the Sync Tab, the e260 will appear on the right.  You should see the internal memory. If you click on Next Device, it will appear again as external memory if there is a card mounted in the e260.  Try transferring the book to Internal Memory.


Dear Bob,

I’m really sorry for the delay of my reply; I waited to get an answer from my library, which I had asked for help, but till now, they haven’t got a solution for my problem…

I followed your instructions (except that I haven’t got an external memory so it wouldn’t be shown anywhere), though I think I already did exactly as you recommended before. But still it doesn’t work. I was able to put an audiobook from the library on another player (sony) today using WMP (without using any special application), so the problem must be caused by the player… any further suggestions what I could do?

Thanks again!