E250v2 can't connect to pc

Hi, I have E250v2 and when I plug it to the computer, it charges but no connect. PC can’t sees it (tried win xp and wmp10, win xp and wmp11 and ubuntu jaunty). I have firmware version 03.01.11F. 

What can I do?

Connection Troubleshooter

I have tried cable with another sansa, it works.  

I think my problem is not hw issue, only fw has some bug.

I tried forcing mass storage mode with l<< button, but didn’t work too.

Do you have the unit OFF when you force MSC?

Yes, I do. I turn off the player, then lock it, then press and hold l<< button, then put the cable into player (it is always in my pc) and it normally switch on. 

Well, it’s possible that you are just not getting a data connection. Different pins in the plug transfer power and data. The power pins are a little tiny bit longer. If you have tried another cable, then the plug in the unit itself might be damaged.

Check in and see if anyone else has a solution, but I don’t know what else to suggest. 

ay caramba :smileyvery-happy:

player shows me connected, but if i try “lsusb” and “dmesg”, here isn’t anything… I think the cable makes fun from me. 

Why don’t you stick to Windows for the moment. Do you get  a connection with XP?

  'cause my primary OS is linux. When I unplugg cable from sansa, it ends showing Connected. With xp no, that happend only once when I try it in linux. I charged my sansa and plugged in microSD card, it shows Update database (text when upgrade music database, I have CZ language and that is my translate) and then shows Connected. I don’t know what happend, but it was only once…  

Message Edited by LivArt on 09-08-2009 10:08 PM

Soo, I bought another cable from ebay, but no luck. 

and, it synchronizes date and time… Soo wtf…