E250 problem in MTP mode - Message pop-up "found new hardware"

Everything was wonderful in MTP & MSC modes. Then one day, after not synching player for 2 weeks, plugged in MTP mode and following message appears…

" Found new hardware sansa E250". Then found new hardware wizard pops up asking for installation of software for new hardware.

Have tried downloading new firmware but this does not help. Also tried recovery mode but device is not recognised in my computer in recovery mode whether MTP or MSC.

Have been through the pc troubleshooter which indicates all ok with pc, problem with device.

Under normal operation MSC works fine with WMP. 

I have another e250 which works just fine


And it worked before? Thats crazy. Does it do this anywhere you take it? Probably gonna get replaced if you call 866.SanDisk

Thanx for the reply

It does it wherever it goes! The other e250 player works fine on my pc so I guess its just some sorta software corruption on this player. Can still use ok and synch from WMP in MSC mode but have lost capability to transfer from napster to go.

Is there any way to get hold of the software (drivers) that are being requested when it is plugged in to pc

the drivers are native to windowsXP and Vista, sandisk does not have them to send out to customers from what I was told. Sounds to me as if you might need to get it replaced.