Downloaded SecureAccess but can’t install on Mac! Help!

Hi, i intend to purchase the Sandisk ultra flair flashdrive but before i purchase i tried to download the SecureAccess on the Macbook just to see if it works. Unfortunately, after i downloaded it and open the installation window, i clicked “Continue” and selected “Mac HD” but it wrote that it can’t be downloaded on this mac. There’s no other selection. I can’t see any No Name or anything. I’m a new macbook user so i’m not really super familiar.

please help

SecureAccess only runs on SanDisk flash drives.

hi there so that means i have to purchase the flashdrive first and plug in first before i can run the secureaccess installation?

Yes.  But do note, many of the flash drives come with SecureAccess already on them.


I have a smiliar problem with my Macbook Air.  `i have successfully installed the SecureAccess file but when I try to open it it fails and send a report to Apple.

I have tried remving the file from the Sandisk and downloading from the SanDisk website and re-installing but it happens again.

Any thoughts?


Secure Access can only be installed on SanDisk drives and the Mac version needs to be used for Mac systems.  Is that what you are using?


Yes I am using the Mac version and successfully downloaded it and installed it onto my SanDisk.  But when I double click the app it tries to open then closes and a report is generated for Apple.