Download Problems

As I learned  in this forum, I  drag from music folder to fuze player. Sync fouled me up too often.

Unfortunately, I have many unknown files in WMP that I edited with correct names and tracks.

While they are visible in WMP10, the files in the music folder stay unedited and not useable to

drag into the fuze.

Any suggestions

Use MP3Tag. It’s dedicated ID3 tagging software. It works great (much better than WMP), and it’s free to boot. :smiley:

Use MP3Tag. It’s dedicated ID3 tagging software. It works great (much better than WMP), and it’s free to boot.

Another thing . . . it’s usually more reliable to edit the tags while the files are on your computer, rather than editing the files that are already on your player. Change & save them on your computer, delete the ones on your player, and transfer the newly-edited ones back over.

I do the editing on the computer using the WMP. While I see the changes in WMP, they do not appear in the music folder from which I drag.

I’ve tried MP3Tag but couldn’t make it work. I rip CD’s that end up in the WMP. Is there a different method?

Make sure you are editing the right files. There may be a copy on your Fuze and another in your computer, and you need to know which one you are fixing.

Also, in mp3tag, under Tools/Options/Tags/Mpeg set the Write option to ID3v2.3 and then ISO-8859-1, and make sure you save it. Then you will be saving tags to the format the Fuze can read best .  Your WMP may be saving them to a different format.

Mp3tag really is better at this than WMP, so give it another try.

And…are you sure you are saving your edits?

And why are you still using the ancient WMP10?:dizzy_face:

I just don’t get it. No confusion between fuze and computer. Could I start at the beginning?

1      I  rip CD to computer using WMP

2      I edit file in WMP and the changes stay there

3      I open music folder for drag to fuze

4      unedited files are transferred?

At what step does MP3 enter the scene?

Wish there was a tutorial for us non/geeks.  The tech instructions seem to be over my head

It’s entirely possible that the source files are left untouched, and the WiMP10 interface has the edited versions.

As long as the metadata shows correctly in WiMP, there’s one simple step left.  Plug in the Fuze (you can use either MSC or MTP mode if desired for this), and select the Sync button.

If a mask pops up asking if you want to set up sync, to do it manually, just click on the Cancel button in this mask. 


The Sync panel on the right that pops up in this mode is your friend, don’t worry about the weird way Microsoft named it.  As a programmer, I’d have named it the “target” list.  Drag and drop your edited albums into this pane, then click on “Start Sync”.

You’ve just told WiMP to send the corrected versions to the target device.

Hey, you’re done, edited versions are sent in this mode. I love using WiMP in this “semi-automatic” mode, it works best.

Perhaps by dragging and dropping from the library, you’re sending the original 'untouched" files.  Give WiMP a try for the transfer.  Note!  Be sure to delete existing copies from the Sansa first, lest you have duplicates.

Bob  :smileyvery-happy:

Thank you Bob for your patience. Yippee it worked for my first transfer.

My fuze  setting was on auto mode under the USB choice and I changed that per your instruction. Would that  have caused my problems?

Now, I will have to find a way to clean up the fuze with the many unknown files. Not looking forward to starting from scratch.

Thank you again


“Unknown” means the files don’t have tags the Fuze can read. Aftist, Album etc. are not folders but lists made from the tags (electronic labels) in the files. You can deal with the unknowns a number of ways.

You could do Settings/System Settings/Format, which erases everything you have put on,  and start anew with your files from WMP.That might be easiest.

Or you could figure out which folders are giving you trouble by going to music and scrolling all the way down, past the first page, to see Folders. That should list the folders, and then the files within them, as if you were looking at them on your computer. Delete duplicates, or ones with bad tags, via your computer.

if you don’t have Folders at the end of the Music list (past Album, Artist, etc.), then you need a firmware update.

Instructions are here.

Use the Manual procedure, which means downloading the All Regions link (1.x or 2.x depending on your hardware), unzipping it onto your desktop, putting the Fuze in MSC mode (Settings/System Settings/USB Mode) and dragging over FuzeA.bin .

Don’t install the Updater, since this is probably the last update.

There are a few notable differences between the modes.  In MTP (Media Transfer Protocol) the Sansa is seen as a media device, allowing protected (DRM) media, automated album art folders, song ratings, and playlists, since WiMP sees the connected device as a media player.  In MSC (Mass Storage Class) mode, the player is accessed directly as a flash drive.

MTP is a virtual mode, or an automated layer on top of MSC, supported by Windows Media Player.  Funny thing is, Microsoft configured it to look almost exactly like regular MSC transfer when using Windows Explorer and drag-and-drop transfer.

WiMP is equally happy, as long as the media is not protected (DRM) transferring files in either mode, contrary to what many may think.

The problems surface when trying to do some manual tasks, such as playlist utilities, since these are path-specific, rather than simply filename specific.  MTP allows something really cool, though it isn’t explained well.  You can right click on a first file, then begin a playlist by dragging the desired files into the new list box that pops up.  To the uninitiated, it looks like you’re actually dragging the files into the list, but it’s just the names.

The completed list can be dropped into one of two places on the Sansa, either into the Music folder, or better yet, keep them where they can be found later, in the Playlist folder.  It can get confusing, but the Sansa knows the difference anyway.

You can build playlists easily in WiMP too, and they will automatically go to the Playlists folder.

There’s a “wall” between MSC and MTP, in which files transferred in one mode are not visible from the computer when connected in the alternate mode, so files look like they’re “missing”, though the Sansa sees ALL files regardless of transfer mode.  This is one of the reasond why many users simply choose one mode exclusively.

Linux or Apple computers generally don’t support MTP mode, so having MSC is quite handy.  For the serious propellerhead, there is libmtp available in the linux realm, but I haven’t had the chance to probe into it.  I have got to set up a cool kubuntu partition for that, as I really love the KDE interface, it’s uber cool.

Glad to confirm that WiMP does yet another thing in the background, namely the metadata, without changing the source file.  As we’ve found, it’s another cool tool that you most likely will not find in the circuitous (code word for confusing as hell) Microsoft help files for WiMP.  I just had a feeling that WiMP might be "repackaging’ the file in transfer, since I have some albums with test images that sometimes pop up on test Sansas, and the difference is that I’ve dragged the source files directly to the Sansa rather than using WiMP.

Bob  :smileyvery-happy:

Thank you both. I printed your comments to digest and restudy.

Was just starting my project and wanted to begin with a blank library in the Wimp. However, it now shows the whole sansa

collection and won’t let me delete.  Library collection won’t play and turns yellow when I try to delete. Message says “can’t read from source disk.”

My guess is that I  must have synced when I manually downloaded one album last night.

Any idea how to get rid of everything in WIMP library and start fresh?

It sounds like WMP is maintaining the old listings even though the actual files are gone, which is why you are getting the “source disk” error message. 

Try this to clear out the WMP database.

That’s the XP procedure–and the drive on my computer where that’s all located is C:, not F:  The path to the database may be a little different in Vista, so if you can’t find the folder, search for Media Index or wmplibrary.