Download new version lost access to all data. Please Help!

I’ve just tried to access my vault on my 8GB flash drive, but rather than just prompting me for my password as it has every other time (and only yesterday too), I got the pop-up asking me to create a new vault. I entered the same details as I had previously; password etc, as I though it could just be a case of the software missing from the PC I was using.

Now however, the new vault is completely empty. There is no sign at all of my old vault nor any of the files I had saved. (Thankfully my most used ones are still just in the normal area of the USB as I was editing them last night, so I’ve not lost my most important files.)

Please can someone tell me if I’ve lost all those files for good, or if there is a way to retrieve them, or even see if they’re still on the drive?

Many thanks


You can try using an undelete app to see if your original vault got deleted and can be recovered.  Other than that I would say your files are gone.  Good that you have backups.  Many people don’t.

These undelete apps are free to download and use.



Additionally, if you try to recover lost files, try not to write’erase something on the flash drive and go straight to using those recovery apps. I have tried this once and it worked out pretty good to me.

OK! That’s why you should always save at least two copies of everything important on separate drives. I hope you can learn a valuable lesson.

But, now, as to the lost files, you may take chances with some data recovery tools. There are many similar data recovery freeware that can often work perfectly than some paid ones like Recuva, TestDisk, iCare Data Recovery Free and 4Card Recovery, etc.

You should select at least one of them to have a try.

But, unfortunately, if these tools also cannot rescue your data, you’d better ask for an expert for help, if the inner data is very, very, very important. 

4Card Recovery is not free.  To recover files you have to enter a registration key which according to this link is 49.99.

That is what I found also.  Although their ‘free’ scan of my deleted files show that the file I’m looking for is on the ‘list’, I would have to pay the $49.00 to find out if in fact it is recoverable.  They say there is a 30 day money back guarantee, but seeing how sneaky they are in presenting their product, I worry that if I don’t want to keep the program, they will not honor the moneyback provision.  Seen THAT done before.


 I worry that if I don’t want to keep the program, they will not honor the moneyback provision.

Yup.  A valid worry IMO.  And especially considering how they create new ids all the time to post there solution to posters problems.

It looks like the vault may have become corrupted. What version of secureaccess are you using? If you are using version 3 you can try using the vault repair feature.

SecureAccess V3 Repair Vault Feature

If you have some other version of secureaccess let us know and we can see if there is something similar for that version that may help recover the vault.