Download from Overdrive Media

I have just purchased a SansaClip 4GB.  I am trying to download an audiobook from OverDrive Media in WMA format.  The USB setting is on MTP.  When I try to transfer the book, I get:  Unable to transfer selected title because [insert] returned 0xC00D2751 error.


I can’t find any help in OverDrive info.  Is this a SansaClip problem?


Try downloading the book to your hard drive.(they put it in My Documents under “My Media”) The drop and drag the book parts to the audiobook file in the sansa. That worked for me. I tried syncing with Overdrive and it didn’t work.

I’m just a newbie, but I did have to search this site and amazon to learn how to get audiobooks from overdrive.  Make sure you update the firmware on the clip before you do anything.  When getting books from overdrive, use the advanced options on overdrive to get the books into the audiobooks folder vs the music folder, this allows the clip to bookmark the place you’re at when going from one book to another or going from a book to music.  I hope this helps a little.  It’s really easy once you’re been able to figure it out.  I was also getting the error message before the firmware was updated.