DOA M230 ?

I bought my 10 yr old son a “beginner” MP3 player about 5 months ago. A Sansa m230 it has been flawless for a very long time (actually bought 2). Now it will not work. I can’t get into the menu to do anything. Thought maybe the battery was low, installed a new battery. Says there are no files in the palyer, if I try to load it with music it works but as soon as I unplug it everything is gone from the MP3 player. I tried to format it and it will not take says windows can’t format device. Tried to get into other modes will not work any help? Thanks in advance.

If I were you, I would call Sandisk.


Thanks, Will do!

I’ve got the exact same problem with my daughters M230.  She’s had it for a year. Last week she left it in her school desk over the weekend.  On Monday when she turned it on, it said No files even thought it has many songs on there.  I tried to delete them and copy the songs back but it won’t let me delete the ones that are on there.  It appears they are gone but when I refresh on my computer screen or replug the usb cable, the same songs are still there.  The only way we can find any songs is to go into search by year and then we can get to 2 or 3.

Try error-checking the player in My Computer…


Microsoft’s disk tools won’t do ANYTHING!!!

I’d say just call SanDisk…

they’re really good about RMA-ing stuff.

I had to RMA my m230 and i got a brand new one no questions asked.

Mayhap for you, but I got my m260 to work after error0checking it…YMMV…


Nope–just TyrAnasazi…:wink: